Bug 1269604 - Libvirt fails to build with sasl
Libvirt fails to build with sasl
Status: CLOSED CURRENTRELEASE
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
Unspecified Other
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-07 12:59 EDT by Jonatan Schlag
Modified: 2016-04-08 12:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-08 12:40:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
terminal outpout (65.09 KB, text/plain)
2015-10-07 12:59 EDT, Jonatan Schlag
no flags Details

  None (edit)
Description Jonatan Schlag 2015-10-07 12:59:40 EDT
Created attachment 1080747 [details]
terminal outpout

Description of problem:

I try to build a libvirt package for the IPFire project (http://www.ipfire.org/).
Without sasl libvirt build fine but with sasl libvirt fails to build with the following message:

CC       rpc/libvirt_net_rpc_la-virnetsaslcontext.lo
In file included from rpc/virnetsaslcontext.h:25,
                 from rpc/virnetsaslcontext.c:26:
/usr/include/sasl/sasl.h:230: error: expected declaration specifiers or '...' before 'size_t'
Makefile:7023: recipe for target 'rpc/libvirt_net_rpc_la-virnetsaslcontext.lo' failed
make[3]: *** [rpc/libvirt_net_rpc_la-virnetsaslcontext.lo] Error 1
make[3]: Leaving directory '/libvirt-1.2.20/src'
Makefile:5119: recipe for target 'all' failed
make[2]: *** [all] Error 2
make[2]: Leaving directory '/libvirt-1.2.20/src'
Makefile:1999: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/libvirt-1.2.20'
Makefile:1896: recipe for target 'all' failed
make: *** [all] Error 2

Version-Release number of selected component (if applicable): 1.2.20


How reproducible:
Build libvirt with:
1. ./configure --prefix=/usr --localstatedir=/var --sysconfdir=/etc --with-openssl --with-sasl --without-uml --without-vbox --without-lxc --without-esx --without-vmware --without-openvz --without-firewalld --without-storage-scsi --without-storage-mpath --without-avahi --with-test-suite -without-dbus --without-storage-lvm --without-pm-utils

2. make

3. the error occurs


Additional info:

Cyrus sasl (2.1.26) is build with 
./configure --prefix=/usr --sysconfdir=/etc \
		            --with-dbpath=/var/lib/sasl/sasldb2 \
		            --with-saslauthd=/var/run/saslauthd \
		            --with-des=no --with-rc4=no

I attached the whole terminal output.

Sincerely Jonatan Schlag

PS.: Sorry for my bad english, i hope you could understand me.
Comment 1 Cole Robinson 2016-03-23 21:04:56 EDT
Hmm it's working here. Can you still reproduce with libvirt.git?
Comment 2 Jonatan Schlag 2016-04-04 09:55:09 EDT
Hi,
thank your for your response and sorry for my late response.
Tomorrow I will try to reproduce this bug with libvirt.git

Regards Jonatan
Comment 3 Ján Tomko 2016-04-04 10:10:28 EDT
This could be fixed by:
commit ab74e8763d2e00b5e9fc4ac39e70dfa5de4d3cc4
Author:     Fabiano Fidêncio <fidencio@redhat.com>
CommitDate: 2016-03-31 17:36:49 +0200

    build: workaround broken SASL header (again)
    
    Compilation for xdg-app failed due to a buggy SASL headers present on
    the used runtime (org.gnome.Sdk 3.18).
    
    In file included from rpc/virnetsaslcontext.h:24:0,
                     from rpc/virnetsaslcontext.c:25:
    /usr/include/sasl/sasl.h:230:38: error: unknown type name 'size_t'
     typedef void *sasl_realloc_t(void *, size_t);
                                          ^
    /usr/include/sasl/sasl.h:235:5: error: unknown type name 'sasl_realloc_t'
         sasl_realloc_t *,
    
    Use the same workaround as commit 1be3dfd did.
    
    Signed-off-by: Ján Tomko <jtomko@redhat.com>

git describe: v1.3.3-rc1-24-gab74e87 contains: v1.3.3-rc2~2
Comment 4 Jonatan Schlag 2016-04-08 12:38:49 EDT
Hi,
I tested it today with libvirt version 1.3.3 and libvirt build now with sasl enabled. 
I will test the binaries tomorrow evening but if libvirt build everything should ok so far I think.

Thank you all for your help. 

Regards Jonatan
Comment 5 Cole Robinson 2016-04-08 12:40:39 EDT
thanks for reporting, closing. if you hit issues with the binaries please file a separate bug since it's likely a different issue

Note You need to log in before you can comment on or make changes to this bug.