Bug 1269624 - bcfg2 does not build correctly anymore
bcfg2 does not build correctly anymore
Status: CLOSED WONTFIX
Product: Fedora EPEL
Classification: Fedora
Component: bcfg2 (Show other bugs)
epel7
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Fabian Affolter
Fedora Extras Quality Assurance
:
Depends On:
Blocks: epel7s390x epel7aarch64
  Show dependency treegraph
 
Reported: 2015-10-07 15:03 EDT by IBM Bug Proxy
Modified: 2016-07-14 09:20 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-14 09:20:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 131423 None None None Never

  None (edit)
Description IBM Bug Proxy 2015-10-07 15:03:00 EDT

    
Comment 1 IBM Bug Proxy 2015-10-07 15:03:04 EDT
The EPEL 7 SRPM for bcfg2 
https://dl.fedoraproject.org/pub/epel/7/SRPMS/b/bcfg2-1.3.4-1.el7.src.rpm
does not build correctly in Mock on s390x. 

6 out of 2078 tests failed and prevented RPM from being built in Mock.
They are caused by either
    1. "NameError: global name 'Bcfg2' is not defined"
or
    2. "OperationalError: unable to open database file"

Some of the tests are skipped because the following modules were not found:
    1. django
      "Ensure that we a) can connect to the database; b) start ... SKIP: Django not found, skipping"
    2. augeas
      "test_BundleNotUpdated (Testlib.TestClient.TestTools.TestPOSIX.TestAugeas.TestPOSIXAugeas) ... SKIP: Python Augeas libraries not found"
    3. YAML
    "test_yaml (Testlib.TestServer.TestPlugins.TestProbes.TestProbeData) ... SKIP: YAML libraries not found, skipping YAML tests"

On the build phase of spec file, python was not found when trying to execute setup.py, which could be the root cause of all these errors.
Comment 2 Yaakov Selkowitz 2015-11-25 15:39:10 EST
The same occurs on aarch64.  Note that this package has been retired in Fedora due to FTBFS during the last two Fedora mass rebuilds.  If this will not be fixed, it needs to be retired from EPEL as well.
Comment 3 Yaakov Selkowitz 2016-04-27 21:58:30 EDT
(In reply to Yaakov Selkowitz from comment #2)
> The same occurs on aarch64.  Note that this package has been retired in
> Fedora due to FTBFS during the last two Fedora mass rebuilds.  If this will
> not be fixed, it needs to be retired from EPEL as well.

Fabian,

In light of the above, do you have any plans to fix this package for Fedora and/or EPEL?
Comment 4 Fabian Affolter 2016-07-14 09:20:09 EDT
Package is retired.

Note You need to log in before you can comment on or make changes to this bug.