Bug 1269633 - SELinux is preventing usbmuxd from 'open' accesses on the file /run/udev/data/+usb:2-0:1.0.
SELinux is preventing usbmuxd from 'open' accesses on the file /run/udev/data...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
23
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:75c79c21bae16c177a640e0a8a3...
:
Depends On:
Blocks: F23FinalFreezeException
  Show dependency treegraph
 
Reported: 2015-10-07 15:25 EDT by James Harrion
Modified: 2015-10-19 17:09 EDT (History)
9 users (show)

See Also:
Fixed In Version: selinux-policy-3.13.1-151.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-19 17:09:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Harrion 2015-10-07 15:25:58 EDT
Description of problem:
I plugged an iPhone 5c into a usb2 socket
SELinux is preventing usbmuxd from 'open' accesses on the file /run/udev/data/+usb:2-0:1.0.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that usbmuxd should be allowed open access on the +usb:2-0:1.0 file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep usbmuxd /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:usbmuxd_t:s0
Target Context                system_u:object_r:udev_var_run_t:s0
Target Objects                /run/udev/data/+usb:2-0:1.0 [ file ]
Source                        usbmuxd
Source Path                   usbmuxd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-147.fc23.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.2.2-300.fc23.x86_64 #1 SMP Wed
                              Sep 30 01:36:26 UTC 2015 x86_64 x86_64
Alert Count                   21
First Seen                    2015-10-07 19:16:32 BST
Last Seen                     2015-10-07 19:16:32 BST
Local ID                      943af988-08e7-443c-82d7-ce75dc9c95fb

Raw Audit Messages
type=AVC msg=audit(1444245392.50:660): avc:  denied  { open } for  pid=3692 comm="usbmuxd" path="/run/udev/data/+usb:2-0:1.0" dev="tmpfs" ino=16082 scontext=system_u:system_r:usbmuxd_t:s0 tcontext=system_u:object_r:udev_var_run_t:s0 tclass=file permissive=0


Hash: usbmuxd,usbmuxd_t,udev_var_run_t,file,open

Version-Release number of selected component:
selinux-policy-3.13.1-147.fc23.noarch

Additional info:
reporter:       libreport-2.6.2
hashmarkername: setroubleshoot
kernel:         4.2.2-300.fc23.x86_64
type:           libreport
Comment 2 Fedora Update System 2015-10-14 08:14:27 EDT
selinux-policy-3.13.1-151.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-4f58ef1352
Comment 3 Fedora Update System 2015-10-14 18:53:04 EDT
selinux-policy-3.13.1-151.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update selinux-policy'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-4f58ef1352
Comment 4 Fedora Blocker Bugs Application 2015-10-17 06:39:15 EDT
Proposed as a Freeze Exception for 23-final by Fedora user pwalter using the blocker tracking app because:

 This is happening on Workstation live media as well. Would be good to fix this before release so that the shipped media doesn't pop up a SELinux warning each time you connect a phone to charge.
Comment 5 Adam Williamson 2015-10-19 16:42:51 EDT
+1 FE.
Comment 6 Stephen Gallagher 2015-10-19 16:45:42 EDT
+1 FE
Comment 7 Mike Ruckman 2015-10-19 16:47:23 EDT
It'd be good to pull this in.

+1 FE
Comment 8 Kevin Fenzi 2015-10-19 16:48:36 EDT
+1 FE
Comment 9 Adam Williamson 2015-10-19 16:50:05 EDT
+4 FE, accepted.
Comment 10 Fedora Update System 2015-10-19 17:09:21 EDT
selinux-policy-3.13.1-151.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.