Bug 1269669 - [supportability] oc describe should show ports information in the same way the UI shows the ports for a pod.
Summary: [supportability] oc describe should show ports information in the same way th...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 3.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: ---
Assignee: Fabiano Franz
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-07 21:48 UTC by Eric Rich
Modified: 2017-03-08 18:26 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-27 09:30:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1933 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.3 Release Advisory 2016-09-27 13:24:36 UTC

Description Eric Rich 2015-10-07 21:48:16 UTC
Description of problem:

When describing a pod the port information is not shown. 

Version-Release number of selected component (if applicable):
$ oc version
oc v3.0.0.1-5-g279b678
kubernetes v0.17.1-804-g496be63

How reproducible: 100% 

Steps to Reproduce:
1. $ oc describe pod hello-openshift

Actual results:

Name:                           hello-openshift
Image(s):                       openshift/hello-openshift:v0.4.3
Host:                           node01-b66c.oslab.opentlc.com/192.168.0.201
Labels:                         name=hello-openshift
Status:                         Running
IP:                             10.1.1.2
Replication Controllers:        <none>
Containers:
  hello-openshift:
    Image:              openshift/hello-openshift:v0.4.3
    State:              Running
      Started:          Wed, 07 Oct 2015 13:16:15 -0400
    Ready:              True
    Restart Count:      0 
Conditions:
  Type          Status
  Ready         True
No events.

Expected results:

The information shown should match that seen by the console. 

Example (text from console): 

Pods

hello-openshift

Status: Running
Node: node01-b66c.oslab.opentlc.com (192.168.0.201)
IP on node: 10.1.1.2
Restart policy: Always
Volumes:

    default-token-sr650

Pod template:
hello-openshift
Image: openshift/hello-openshift:v0.4.3
Ports: 8080 (TCP) ⟶ 36061

Additional info:

Comment 2 Fabiano Franz 2016-07-04 21:36:38 UTC
Fixed in master, the pod describer now displays the port for each container.

Comment 3 XiaochuanWang 2016-07-07 08:14:35 UTC
verified on oc v3.3.0.2
openshift  v3.2.1.5-1-g71b9ccf

Ports are described in the same way as web console.
Ports: 3306/TCP

Comment 5 errata-xmlrpc 2016-09-27 09:30:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1933


Note You need to log in before you can comment on or make changes to this bug.