Bug 1269675 - many packages fail to build with scriptlet errors for f23 chroot on f23 host
many packages fail to build with scriptlet errors for f23 chroot on f23 host
Status: CLOSED DUPLICATE of bug 1268883
Product: Fedora
Classification: Fedora
Component: mock (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Clark Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-07 18:37 EDT by Cole Robinson
Modified: 2015-10-08 03:13 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-08 03:13:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cole Robinson 2015-10-07 18:37:01 EDT
$ rpm -q mock dnf yum
mock-1.2.13-2.fc23.noarch
dnf-1.1.2-4.fc23.noarch
yum-3.4.3-507.fc23.noarch


Most package fail to 'fedpkg mockbuild' for me with f23 host in f23 chroot. Original example is qemu, but a simpler example is parted. I suspect this is reproducible for anyone on an f23 host:

fedpkg co parted
cd parted
fedpkg switch-branch f23
fedpkg mockbuild
...
Total                                              567 kB/s | 8.1 MB  00:14     
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction (shutdown inhibited)
  Installing : crontabs-1.11-11.20150630git.fc23.noarch                    1/59 
  Installing : cronie-anacron-1.5.0-3.fc23.x86_64                          2/59 
warning: %post(cronie-anacron-1.5.0-3.fc23.x86_64) scriptlet failed, exit status 126
...


There's more complete output in my posting to fedora devel:

https://lists.fedoraproject.org/pipermail/devel/2015-September/215183.html
https://lists.fedoraproject.org/pipermail/devel/2015-October/215341.html

I've played with it a bit since then, and if I edit /etc/mock/site-defaults.cfg and add

config_opts['yum_command'] = '/usr/bin/yum-deprecated'

Builds start working again, at least it did for my parted test case. So maybe this is a dnf issue but I'll let yall sort it out since I don't really know how to debug further
Comment 1 Cole Robinson 2015-10-07 19:24:37 EDT
Sorry, ignore the bit about yum-deprecated, I got confused, it doesn't make a difference.

But what definitely super for-realzies does make things work is downgrading to older mock-1.2.12-1.fc23 (which I grabbed from koji)
Comment 2 Miroslav Suchý 2015-10-08 03:13:17 EDT

*** This bug has been marked as a duplicate of bug 1268883 ***

Note You need to log in before you can comment on or make changes to this bug.