Bug 1269678 - Please enable CONFIG_MEMORY_HOTREMOVE
Please enable CONFIG_MEMORY_HOTREMOVE
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-07 19:01 EDT by Cole Robinson
Modified: 2016-09-23 15:27 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-23 15:27:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cole Robinson 2015-10-07 19:01:31 EDT
CONFIG_MEMORY_HOTREMOVE is unset for Fedora kernels, but CONFIG_MEMORY_HOTPLUG _is_ set. I was just testing memory hotplug with libvirt + qemu and noticed this, I figured I'd request for it to be enabled for virt testing/dev.

I looked for an explanation for why it's off in dist-git but all I got was this:

commit 2ee9f1482920f6d831eb6d70458bd0988394982b
Author: Dave Jones <davej@redhat.com>
Date:   Fri Jan 13 17:33:51 2012 -0500

    Disable memory hotplug on x86-64


Which seems to be in the midst of disabling a bunch of misc kernel stuff.
Comment 1 Laura Abbott 2016-09-23 15:25:43 EDT
*********** MASS BUG UPDATE **************
 
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 23 kernel bugs.
 
Fedora 23 has now been rebased to 4.7.4-100.fc23.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 24 or 25, and are still experiencing this issue, please change the version to Fedora 24 or 25.
 
If you experience different issues, please open a new bug report for those.
Comment 2 Cole Robinson 2016-09-23 15:27:29 EDT
Looks like latest kernels have this:

$ cat /boot/config-4.7.4-200.fc24.x86_64 | grep HOTREMOVE
CONFIG_MEMORY_HOTREMOVE=y
CONFIG_ARCH_ENABLE_MEMORY_HOTREMOVE=y

Note You need to log in before you can comment on or make changes to this bug.