This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1269702 - Glusterfsd crashes on pmap signin failure
Glusterfsd crashes on pmap signin failure
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: core (Show other bugs)
3.7.5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pranith Kumar K
:
: 1293742 (view as bug list)
Depends On: 1269696
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-07 22:12 EDT by Pranith Kumar K
Modified: 2016-05-31 08:32 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1269696
Environment:
Last Closed: 2016-04-19 03:47:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pranith Kumar K 2015-10-07 22:12:52 EDT
+++ This bug was initially created as a clone of Bug #1269696 +++

Description of problem:
Following crash is seen on the brick processes:
Program terminated with signal SIGSEGV, Segmentation fault.
#0  0x0000000000407eae in emancipate (ctx=0x0, ret=-1) at /home/jenkins/root/workspace/rackspace-regression-2GB-triggered/glusterfsd/src/glusterfsd.c:1329
1329	/home/jenkins/root/workspace/rackspace-regression-2GB-triggered/glusterfsd/src/glusterfsd.c: No such file or directory.
(gdb) bt
#0  0x0000000000407eae in emancipate (ctx=0x0, ret=-1) at /home/jenkins/root/workspace/rackspace-regression-2GB-triggered/glusterfsd/src/glusterfsd.c:1329
#1  0x000000000040f806 in mgmt_pmap_signin_cbk (req=0x7f51e806fdec, iov=0x7f51eece15e0, count=1, myframe=0x7f51e806ee1c) at /home/jenkins/root/workspace/rackspace-regression-2GB-triggered/glusterfsd/src/glusterfsd-mgmt.c:2174
#2  0x00007f51fab1a6c7 in saved_frames_unwind (saved_frames=0x1535fb0) at /home/jenkins/root/workspace/rackspace-regression-2GB-triggered/rpc/rpc-lib/src/rpc-clnt.c:366
#3  0x00007f51fab1a766 in saved_frames_destroy (frames=0x1535fb0) at /home/jenkins/root/workspace/rackspace-regression-2GB-triggered/rpc/rpc-lib/src/rpc-clnt.c:383
#4  0x00007f51fab1abf8 in rpc_clnt_connection_cleanup (conn=0x1534b70) at /home/jenkins/root/workspace/rackspace-regression-2GB-triggered/rpc/rpc-lib/src/rpc-clnt.c:536
#5  0x00007f51fab1b670 in rpc_clnt_notify (trans=0x1534fc0, mydata=0x1534b70, event=RPC_TRANSPORT_DISCONNECT, data=0x1534fc0) at /home/jenkins/root/workspace/rackspace-regression-2GB-triggered/rpc/rpc-lib/src/rpc-clnt.c:856
#6  0x00007f51fab17af3 in rpc_transport_notify (this=0x1534fc0, event=RPC_TRANSPORT_DISCONNECT, data=0x1534fc0) at /home/jenkins/root/workspace/rackspace-regression-2GB-triggered/rpc/rpc-lib/src/rpc-transport.c:544
#7  0x00007f51f0305621 in socket_event_poll_err (this=0x1534fc0) at /home/jenkins/root/workspace/rackspace-regression-2GB-triggered/rpc/rpc-transport/socket/src/socket.c:1151
#8  0x00007f51f030a34c in socket_event_handler (fd=9, idx=1, data=0x1534fc0, poll_in=1, poll_out=0, poll_err=24) at /home/jenkins/root/workspace/rackspace-regression-2GB-triggered/rpc/rpc-transport/socket/src/socket.c:2356
#9  0x00007f51fadcb7c0 in event_dispatch_epoll_handler (event_pool=0x14fac90, event=0x7f51eece1e70) at /home/jenkins/root/workspace/rackspace-regression-2GB-triggered/libglusterfs/src/event-epoll.c:575
#10 0x00007f51fadcbbae in event_dispatch_epoll_worker (data=0x1536180) at /home/jenkins/root/workspace/rackspace-regression-2GB-triggered/libglusterfs/src/event-epoll.c:678
#11 0x00007f51fa032a51 in start_thread () from ./lib64/libpthread.so.0
#12 0x00007f51f999c93d in clone () from ./lib64/libc.so.6



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2015-10-29 03:32:07 EDT
REVIEW: http://review.gluster.org/12312 (glusterfsd: Initialize ctx, cmd_args) posted (#2) for review on release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 2 Vijay Bellur 2015-11-19 11:49:35 EST
REVIEW: http://review.gluster.org/12312 (glusterfsd: Initialize ctx, cmd_args) posted (#3) for review on release-3.7 by Dan Lambright (dlambrig@redhat.com)
Comment 3 Vijay Bellur 2015-11-23 14:15:52 EST
REVIEW: http://review.gluster.org/12312 (glusterfsd: Initialize ctx, cmd_args) posted (#4) for review on release-3.7 by Vijay Bellur (vbellur@redhat.com)
Comment 4 Vijay Bellur 2015-11-24 22:14:40 EST
COMMIT: http://review.gluster.org/12312 committed in release-3.7 by Vijay Bellur (vbellur@redhat.com) 
------
commit f054680c073d571f9228fabf91fa58416ef86a5f
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Wed Oct 7 18:39:42 2015 +0530

    glusterfsd: Initialize ctx, cmd_args
    
            Backport of http://review.gluster.org/12311
    
    Change-Id: I9c71ae264665b7bba609c7f86cf42a52a6b47260
    BUG: 1269702
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/12312
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 5 Kaushal 2016-04-19 03:47:08 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 6 Niels de Vos 2016-05-31 08:32:36 EDT
*** Bug 1293742 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.