Bug 1269703 - [RFE] Add a "Storage Domain" column to a VM's Disks tab display
[RFE] Add a "Storage Domain" column to a VM's Disks tab display
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs (Show other bugs)
3.5.4
All Linux
medium Severity medium
: ovirt-3.6.0-rc3
: 3.6.0
Assigned To: Allon Mureinik
Gil Klein
storage
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-07 22:19 EDT by Chris Henderson
Modified: 2016-02-10 14:21 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-08 08:17:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Henderson 2015-10-07 22:19:23 EDT
1. Proposed title of this feature request  
[RFE] Add a "Storage Domain" column to a VM's Disks tab display 
      

3. What is the nature and description of the request?  

When I have a VM selected, on it Disks tab it lists out all the Disks 
associated with the VM.  Please add another column in the field that 
tells which STORAGE DOMAIN it belongs to. That way I know in a single 
glance where each VM disk is being hosted with respect to that VM.

4. Why does the customer need this? 

Ease of managing VM's and their associated disks.

5. How would the customer like to achieve this?
	
Add a "Storage Domain" column to the VM's Disks tab.
  
6. For each functional requirement listed, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented.  

Functionality in question 5 would exist.
      
7. Is there already an existing RFE upstream or in Red Hat Bugzilla?  No

8. Is the sales team involved in this request and do they have any additional input?  They are aware of the RFE, but no additional input.
      
9. List any affected packages or components. WebUI 
      
10. Would the customer be able to assist in testing this functionality if implemented?  Yes
Comment 2 Allon Mureinik 2015-10-08 06:39:26 EDT
Einav/Daniel/Tal - any insight?

Yaniv - is this really worthy of an RFE, or should be just treat it as a bug?
Comment 3 Allon Mureinik 2015-10-08 08:12:15 EDT
Wait a sec. The disk tabs (both the main tab and the subtab under VM) have a radio button to select what you're viewing - all disks, images or direct luns. The default is all disks, which only displays the columns that all disks have. If you change it to "images", the storage domain will be visible. 

See attached screenshot for example.
Comment 5 Allon Mureinik 2015-10-08 08:17:00 EDT
I'm closing this bug for 3.6.0 since that's when it was submitted, but please communicate to the customer that the same functionality is available in 3.5 they reported it on (and frankly, back since at least 3.2, if not earlier).

Note You need to log in before you can comment on or make changes to this bug.