Bug 1269713 - The difference setting xml place of virtio and scsi ioeventfd disk should be descript more clearly
The difference setting xml place of virtio and scsi ioeventfd disk should be ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: doc-Virtualization_Deployment_and_Administration_Guide (Show other bugs)
7.2
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Jiri Herrmann
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-07 23:34 EDT by Xuesong Zhang
Modified: 2016-11-07 09:49 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-07 09:49:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xuesong Zhang 2015-10-07 23:34:47 EDT
Document URL: 
26.18.1.6. Driver element
http://documentation-devel.engineering.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/Virtualization_Deployment_and_Administration_Guide/sect-Manipulating_the_domain_xml-Devices.html#sect-Devices-Hard_drives_floppy_disks_CDROMs

26.18.4 . Controllers
http://documentation-devel.engineering.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/Virtualization_Deployment_and_Administration_Guide/sect-Manipulating_the_domain_xml-Devices.html#sect-Devices-Controllers

Section Number and Name: 

Describe the issue: 
As you can see in the following libvirt.org, there is one new optional element "ioeventfd" for the scsi controller.
http://libvirt.org/formatdomain.html#elementsControllers
......
ioeventfd
The optional ioeventfd attribute specifies whether the controller should use I/O asynchronous handling or not. Accepted values are "on" and "off". Since 1.2.18
......

There is another ioeventfd element in disk xml section, following is for you reference.
http://libvirt.org/formatdomain.html#elementsDisks
......
The optional ioeventfd attribute allows users to set domain I/O asynchronous handling for disk device. The default is left to the discretion of the hypervisor. Accepted values are "on" and "off". Enabling this allows qemu to execute VM while a separate thread handles I/O. Typically guests experiencing high system CPU utilization during I/O will benefit from this. On the other hand, on overloaded host it could increase guest I/O latency. Since 0.9.3 (QEMU and KVM only) In general you should leave this option alone, unless you are very certain you know what you are doing
......


They are all allow users to set domain I/O asynchronous handling for disk device. The difference is the "ioeventfd" attribute in <disk...> xml section is for the virtio disk, the "ioeventfd" attribute in <controller type='scsi'...> xml section is for the scsi disk. Please highlight the difference in the administrator guide, otherwise the cumstomer will be confused.

Suggestions for improvement: 

Additional information:

Note You need to log in before you can comment on or make changes to this bug.