Bug 1269717 - hsqldb.service unit file should have After=network.target
hsqldb.service unit file should have After=network.target
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: hsqldb (Show other bugs)
7.1
Unspecified Unspecified
medium Severity medium
: rc
: 7.3
Assigned To: Mikolaj Izdebski
Vaclav Danek
: EasyFix
Depends On:
Blocks: 1203710 1305230
  Show dependency treegraph
 
Reported: 2015-10-08 00:42 EDT by Ryan Sawhill
Modified: 2016-11-03 19:31 EDT (History)
5 users (show)

See Also:
Fixed In Version: hsqldb-1.8.1.3-14.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 19:31:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Sawhill 2015-10-08 00:42:03 EDT
Description of problem:

  I'm not familiar with hsqldb, but I was doing an audit of all systemd service files for network-capable services and noticed that hsqldb.service has no "After=" setting.

  In contrast, mariadb.service and postgresql.service each have "After=network.target".

  To be clear, we're not talking about adding a dependency on networking -- that would be "Wants=" or "Requires=", neither of which postgresql/mariadb have  -- just making it so that we can wait a little longer for networking to start, *if networking is enabled*.

Fix:

  Explicitly, the fix would be to add "After=network.target" as a new line under the "[Unit]" section of /usr/lib/systemd/system/hsqldb.service.
Comment 1 Mikolaj Izdebski 2015-10-08 04:50:30 EDT
Fixed in Fedora: http://pkgs.fedoraproject.org/cgit/hsqldb.git/commit/?id=23876ec
Comment 6 errata-xmlrpc 2016-11-03 19:31:06 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2160.html

Note You need to log in before you can comment on or make changes to this bug.