Bug 1269745 - Change in alignment of parameters list in puppet class parameters tab of puppet class after checking and unchecking override check box
Summary: Change in alignment of parameters list in puppet class parameters tab of pupp...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: Nightly
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Tomer Brisker
QA Contact: Corey Welton
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks: 1278718
TreeView+ depends on / blocked
 
Reported: 2015-10-08 06:59 UTC by Jitendra Yejare
Modified: 2019-09-25 20:51 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:57:40 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshots attached of para (141.91 KB, image/png)
2015-10-08 06:59 UTC, Jitendra Yejare
no flags Details


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 12096 None None None 2016-04-22 16:41:11 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Jitendra Yejare 2015-10-08 06:59:03 UTC
Created attachment 1080865 [details]
Screenshots attached of para

Description of problem:
Change in alignment of parameters list in puppet class parameters tab of puppet class, after checking and unchecking override check box.

Version-Release number of selected component (if applicable):
foreman-1.10.0-0.develop.201510052033gitb064a42.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1. In Configure -> Classes, click on any puppet class to see the list of parameter in 'Puppet Class Parameter' tab.
2. Click on any parameter in the list to edit it.
3. Check the 'override' checkbox to override the default value and then observe that the Flag image is displayed prior to parameter name in the list.
4. Uncheck the Override button.

Actual results:
The parameter name moves few centimetres to the left in the list. This is applicable for all the parameters in the list.

Expected results:
The alignment should be proper and same for all the parameters in the list.

Additional info:

Comment 2 Bryan Kearney 2015-10-08 18:00:29 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/12096 has been closed
-------------
Anonymous
Applied in changeset commit:e33ae20294881c17d45ba9070c68eb7de20a13a2.

Comment 4 Tazim Kolhar 2015-11-10 09:28:35 UTC
VERIFIED:
# rpm -qa | grep foreman
foreman-gce-1.11.0-0.develop.201511062002gitd3c978e.el7.noarch
hp-bl465cg7-01.rhts.eng.bos.redhat.com-foreman-client-1.0-1.noarch
hp-bl465cg7-01.rhts.eng.bos.redhat.com-foreman-proxy-1.0-1.noarch
foreman-selinux-1.11.0-0.develop.201510071426git6234447.el7.noarch
tfm-rubygem-foreman_bootdisk-6.0.0-2.fm1_10.el7.noarch
foreman-release-1.11.0-0.develop.201511062002gitd3c978e.el7.noarch
foreman-ovirt-1.11.0-0.develop.201511062002gitd3c978e.el7.noarch
tfm-rubygem-hammer_cli_foreman_tasks-0.0.8-1.el7.noarch
foreman-libvirt-1.11.0-0.develop.201511062002gitd3c978e.el7.noarch
foreman-postgresql-1.11.0-0.develop.201511062002gitd3c978e.el7.noarch
foreman-1.11.0-0.develop.201511062002gitd3c978e.el7.noarch
tfm-rubygem-foreman_gutterball-0.0.1-3.el7.noarch
hp-bl465cg7-01.rhts.eng.bos.redhat.com-foreman-proxy-client-1.0-1.noarch
tfm-rubygem-foreman_discovery-4.1.2-1.fm1_11.el7.noarch
foreman-compute-1.11.0-0.develop.201511062002gitd3c978e.el7.noarch
tfm-rubygem-hammer_cli_foreman_docker-0.0.3-4.el7.noarch
foreman-debug-1.11.0-0.develop.201511062002gitd3c978e.el7.noarch
foreman-proxy-1.11.0-0.develop.201511020918git26aba85.el7.noarch
foreman-vmware-1.11.0-0.develop.201511062002gitd3c978e.el7.noarch
tfm-rubygem-hammer_cli_foreman-0.4.0-1.201510201150gitab068d9.el7.noarch
tfm-rubygem-foreman_hooks-0.3.9-1.el7.noarch
tfm-rubygem-foreman-tasks-0.7.6-1.fm1_10.el7.noarch
foreman-release-scl-1-1.el7.x86_64
tfm-rubygem-foreman_docker-1.4.1-2.fm1_10.el7.noarch
tfm-rubygem-hammer_cli_foreman_bootdisk-0.1.3-3.el7.noarch

steps:
1. In Configure -> Classes, click on any puppet class to see the list of parameter in 'Puppet Class Parameter' tab.
2. Click on any parameter in the list to edit it.
3. Check the 'override' checkbox to override the default value and then observe that the Flag image is displayed prior to parameter name in the list.
4. Uncheck the Override button.

The alignment is proper and same for all the parameters in the list.

Comment 8 errata-xmlrpc 2016-07-27 08:57:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.