Bug 1269765 - Auto import hosted engine domain
Auto import hosted engine domain
Status: CLOSED DUPLICATE of bug 1269768
Product: ovirt-engine
Classification: oVirt
Component: BLL.HostedEngine (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ovirt-3.6.0-ga
: ---
Assigned To: Sandro Bonazzola
Ilanit Stein
integration
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-08 03:49 EDT by Roy Golan
Modified: 2015-10-19 04:46 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-19 04:46:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Roy Golan 2015-10-08 03:49:49 EDT
Description of problem:


The hosted engine storage domain is a critical part of the
managing that VM with the engine.
  
In order to reduce manual intervention, we can collect all
data and import that domain automatically.
  
The flow would be:
  
1. Analyze the VM (VM monitoring) and check if its MANAGED
2. if not MANAGED, try to import the SD
3. detect the SD details by crossmatching the domain info (we have the
   name in config) with the output of getDeviceList, to get connection
   details of ISCSI
4. import the SD
5. if SD imported, import the VM

Expected results:

After installation, when there is an ACTIVE DC where the hosted engine runs, the storage domain should be imported automatically.

After upgrade, it should be the same.
Comment 1 Sandro Bonazzola 2015-10-19 04:46:43 EDT

*** This bug has been marked as a duplicate of bug 1269768 ***

Note You need to log in before you can comment on or make changes to this bug.