Bug 1269791 - check for missing provider while service provisioning of catalog item type orchestration
Summary: check for missing provider while service provisioning of catalog item type or...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Provisioning
Version: 5.4.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.5.0
Assignee: Bill Wei
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-08 08:39 UTC by Aziza Karol
Modified: 2016-06-29 09:15 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-16 14:57:29 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Aziza Karol 2015-10-08 08:39:42 UTC
Created attachment 1080930 [details]
no provider selected

Description of problem:


Version-Release number of selected component (if applicable):
5.4.3.0.20151001120745_d11cf59 

How reproducible:
100%

Steps to Reproduce:
1.create a catalog item of type orchestration(do not select provider)
2.order the service
3.

Actual results:
No flash message displayed if no provider selected.
Also the request page displays "Service Provisioned Successfully". see attached screenshots

Expected results:
Validation message required

Additional info:

Comment 3 Greg McCullough 2015-10-09 17:36:08 UTC
Not selecting a provider is valid as the selection can be delayed until automate processing.

The issue here seems to be the "Service Provisioned Successfully" if the orchestration template was not properly provisioned.

Comment 4 Bill Wei 2015-10-12 19:08:31 UTC
As Greg's said above, there is no flash error message if no provider is selected from the combobox since it may be provided through user script.

I have tested with steps but I saw the the provision failure as designed.

Please retest and make sure the provision entry point is correctly pointing to cloud orchestration.


Note You need to log in before you can comment on or make changes to this bug.