This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1269796 - deprecated config values may brake the upgrade process
deprecated config values may brake the upgrade process
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Backend.Core (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-3.6.1
: 3.6.1
Assigned To: Eli Mesika
Jiri Belka
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-08 04:55 EDT by Eli Mesika
Modified: 2016-01-19 10:37 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-19 10:37:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑3.6.z?
rule-engine: planning_ack?
masayag: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 47033 master MERGED db: executed config cleanup as upgrade script Never
oVirt gerrit 47117 ovirt-engine-3.6 MERGED db: executed config cleanup as upgrade script Never
oVirt gerrit 47631 ovirt-engine-3.6 MERGED db: Undo removal of valid config values Never

  None (edit)
Description Eli Mesika 2015-10-08 04:55:29 EDT
Description of problem:

Up to now when a config entry was deprecated, we had to remove it in the
pre-upgrade step calling fn_db_delete_config_value from 0000_config.sql.

This may be problematic if a reference to the deleted entry exists in one
of the upgrade scripts, in such case the entry will be removed in the
pre-upgrade step and then the upgrade script referring this key will fail
and cause all the upgrade process to fail.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Attempt to delete a config key that exists in one of the upgrade scripts
2. run upgrade

Actual results:
Upgrade process fails on the script that refers the removed config key 

Expected results:
Upgrade scripts succeeds 

Additional info:
all deprecated config entries should be moved to an upgrade script
resolving this issue and adding additional benefit of executing all this
mass removals only once instead doing that again and again on each
upgrade.
Comment 1 Red Hat Bugzilla Rules Engine 2015-10-19 06:54:46 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 2 Yaniv Lavi (Dary) 2015-10-29 08:38:14 EDT
In oVirt testing is done on single release by default. Therefore I'm removing the 4.0 flag. If you think this bug must be tested in 4.0 as well, please re-add the flag. Please note we might not have testing resources to handle the 4.0 clone.
Comment 3 Jiri Belka 2016-01-14 08:38:07 EST
ok, rhevm-dbscripts-3.6.2.5-0.1.el6.noarch

no 'fn_db_delete_config*' in pre_upgrade scripts.

Note You need to log in before you can comment on or make changes to this bug.