Bug 1269804 - Dependency on spawn-fcgi that will be removed
Dependency on spawn-fcgi that will be removed
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: lighttpd (Show other bugs)
24
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
http://permalink.gmane.org/gmane.linu...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-08 05:24 EDT by Petr Pisar
Modified: 2016-06-28 13:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-28 13:03:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2015-10-08 05:24:12 EDT
lighttpd-fastcgi package run-requires spawn-fcgi. spawn-fcgi is orphaned now and it will be removed from distribution if nobody will adopt it. Is the dependency needed?

lighttpd.spec says:

%package fastcgi
Summary: FastCGI module and spawning helper for lighttpd and PHP configuration
Group: System Environment/Daemons
Requires: %{name} = %{version}-%{release}
# Not really a requirement, but it used to be included (until 1.4.20-5)
Requires: spawn-fcgi

And grepping the lighttpd-fastcgi does reveal any spawn-fcgi invocation. There only few documentation files mentioning it.

I feel spawn-fcgi package itself is not needed if you have systemd <http://redmine.lighttpd.net/projects/spawn-fcgi/wiki/Systemd>. Indeed the package in Fedora delivers System V init scripts only.

I propose to remove spawn-fcgi dependency from the lighttpd-fastcgi package.

(Notice: I have no experience with FastCGI, so possibly I'm not right. I noticed this issue because many Perl packages depends on lighttpd.)
Comment 1 Jan Kurik 2016-02-24 10:31:28 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 2 Scott Wilkerson 2016-06-28 13:03:05 EDT
spawn-fcgi was only orphaned for a short time.  I am the active maintainer and it will continue to be available.

Note You need to log in before you can comment on or make changes to this bug.