This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1269805 - Screens not properly activated when connecting to docking station
Screens not properly activated when connecting to docking station
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-08 05:24 EDT by Jan Vlug
Modified: 2016-07-19 14:08 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-19 14:08:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Logging during the problem (436.34 KB, text/plain)
2015-10-08 05:26 EDT, Jan Vlug
no flags Details

  None (edit)
Description Jan Vlug 2015-10-08 05:24:44 EDT
Description of problem:
When I dock my already up and running laptop with the lid open to a docking station with two screens, the screens are not activated. All screens stay black, although I do see the mouse pointer (and can sometimes move it.

See the attached log file:
Around 10:18 the system was connected to the docking station

I tried to open console with <CTRL><ALT><F?>
I tried to restart the gnome session by pressing <Alt><F2>r

(10:38?) Finally I forced a hard reboot by holding the power button for several seconds.

After the reboot (laptop was still connected with open lid to the docking station with two additional screens), all screens (also the one on the laptop) came up correctly.
Comment 1 Jan Vlug 2015-10-08 05:26 EDT
Created attachment 1080936 [details]
Logging during the problem
Comment 2 Jan Vlug 2015-12-15 10:42:53 EST
See also: bug 1275770
Comment 3 Scott Williams 2016-01-05 15:33:36 EST
There are some recent commits to fix screen blanking.  It doesn't solve my issue, but I can post my source/x86_64 RPM and spec if it's helpful for testing.
Comment 4 Scott Williams 2016-01-05 15:36:43 EST
Actually, I noticed that your issue is with nouveau and not i915, so it won't help, however, this commit might fix your issue: http://cgit.freedesktop.org/nouveau/xf86-video-nouveau/commit/?id=6e6d8ac1c7b4ee047a7b40b95dea1e65a7c3211a
Comment 5 Fedora End Of Life 2016-07-19 14:08:57 EDT
Fedora 22 changed to end-of-life (EOL) status on 2016-07-19. Fedora 22 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.