Bug 126983 - snmpd crashes when hr_storage module is loaded AND no CD in drive
snmpd crashes when hr_storage module is loaded AND no CD in drive
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: net-snmp (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-29 23:10 EDT by Christopher DeMarco
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 03:23:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
snmpd.conf (525 bytes, text/plain)
2004-07-12 20:57 EDT, Christopher DeMarco
no flags Details
Config from /proc/ide (10.25 KB, text/plain)
2004-07-12 21:06 EDT, Christopher DeMarco
no flags Details

  None (edit)
Description Christopher DeMarco 2004-06-29 23:10:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040615 Firefox/0.9

Description of problem:
snmpd crashes when doing snmpwalk.  syslog logs  

  kernel: cdrom: open failed.

just before snmpd crashes.

If a CD is in the drive, then the mibwalk finishes successfully.  

Version-Release number of selected component (if applicable):
net-snmp-5.1.1-2

How reproducible:
Always

Steps to Reproduce:
1.  service snmpd [re]start
2.  snmpwalk -v 2c -c public localhost
3.  service snmpd status
    

Actual Results:  snmpd dead, but subsys locked.
syslog logs many instances of
  
  kernel: cdrom: open failed.


Expected Results:  Full MIB should have been walked!

Additional info:

Work-around is as follows - start snmpd with 

  -I -hr_disk

option.
Comment 1 Phil Knirsch 2004-07-12 11:16:22 EDT
I just tested this with an umodified snmpd installation here and it
works without a problem.

Have you changed something to the config file?

Read ya, Phil
Comment 2 Christopher DeMarco 2004-07-12 20:57:55 EDT
Created attachment 101846 [details]
snmpd.conf

snmpd.conf used when the problem occurred
Comment 3 Christopher DeMarco 2004-07-12 21:05:04 EDT
Here's my ``uname -a'':
Linux bugs.md.com.my 2.6.6-1.435.2.3smp #1 SMP Thu Jul 1 08:36:21 EDT
2004 i686 i686 i386 GNU/Linux

The kernel in use at the time was *either* the above or more probably
the stock FC2 smp kernel 2.6.6-1.435.2.3smp since the above wasn't
released until July 1.

From ``lspci -v'': 

00:1f.1 IDE interface: Intel Corp. 82801EB/ER (ICH5/ICH5R) Ultra ATA
100 Storage Controller (rev 02) (prog-if 8a [Master SecP PriP])
        Subsystem: Intel Corp.: Unknown device 4246
        Flags: bus master, medium devsel, latency 0, IRQ 185
        I/O ports at <unassigned>
        I/O ports at <unassigned>
        I/O ports at <unassigned>
        I/O ports at <unassigned>
        I/O ports at ffa0 [size=16]
        Memory at 3f000000 (32-bit, non-prefetchable) [size=1K]

00:1f.2 IDE interface: Intel Corp. 82801EB (ICH5) Serial ATA 150
Storage Controller (rev 02) (prog-if 8f [Master SecP SecO PriP PriO])
        Subsystem: Intel Corp.: Unknown device 4246
        Flags: bus master, 66Mhz, medium devsel, latency 0, IRQ 185
        I/O ports at e800
        I/O ports at e400 [size=4]
        I/O ports at e000 [size=8]
        I/O ports at dc00 [size=4]
        I/O ports at d800 [size=16]

Hmmm... what else?
Comment 4 Christopher DeMarco 2004-07-12 21:06:01 EDT
Created attachment 101847 [details]
Config from /proc/ide
Comment 5 Christopher DeMarco 2004-07-12 21:08:12 EDT
net-snmp is version 5.1.1-2
Comment 6 Matthew Booth 2004-09-29 19:28:25 EDT
I also discovered this problem on FC2 using net-snmp-5.1.1-2. However,
a bit of digging showed that this is already documented. man
snmpd.conf details the ignoredisk directive which is specifically to
work around this problem. I added:

ignoredisk /dev/hd[cd]

and snmpwalk now successfully completes. It also still returns
information on all other disks.
Comment 7 Radek Vokal 2004-10-04 03:23:34 EDT
I've tested this bug with net-snmp-5.1.2-9 and it didn't appear.
Anyway the `ignoredisk` option allows to skip drive which causes the
problem and fixes it. 

Note You need to log in before you can comment on or make changes to this bug.