Bug 1269851 - hdf SRPM does not build correctly on s390x, aarch64
hdf SRPM does not build correctly on s390x, aarch64
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: hdf (Show other bugs)
epel7
s390x Linux
high Severity medium
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: epel7s390x epel7aarch64
  Show dependency treegraph
 
Reported: 2015-10-08 07:02 EDT by IBM Bug Proxy
Modified: 2016-02-28 15:24 EST (History)
9 users (show)

See Also:
Fixed In Version: hdf-4.2.10-7.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-28 15:24:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 131485 None None None Never

  None (edit)
Description IBM Bug Proxy 2015-10-08 07:02:21 EDT

    
Comment 1 IBM Bug Proxy 2015-10-08 07:02:23 EDT
The EPEL 7 SRPM for hdf 
https://dl.fedoraproject.org/pub/epel/7/SRPMS/h/hdf-4.2.10-1.el7.src.rpm 
does not build correctly in Mock on s390x due to test failures.

The following tests have failed and prevents RPM from being built:

  ===========================================
  HDF Library Fortran Interface Tests Setup
  ===========================================
  ===========================================
  HDF Library Fortran Interface Tests Started
  ===========================================
 Built with HDF Library Version: 4.2.*
 HDF Version 4.2 Release 10, February 7, 2014
  Testing -- slab
  Testing -- r24
  Testing -- an
  Testing -- anfile
  Testing -- manf
  Testing -- mgrf
  Testing -- p
  Testing -- r8
  Testing -- sdmms
  Testing -- sdnmms
  Testing -- sdnnt
  Testing -- sdnt
  Testing -- sdstr
  Testing -- vsetf
  Testing -- vsetblock
  Testing -- vgroups
  Testing -- vattrf
  Testing -- stubs
  >>>Failure:  could not close file.
     DFerror =            8
  >>>Failure:  Error            4  opening file.
     Quiting.
  =====================================
            1  Fortran test(s) failed
  =====================================

  =============================
  Running ncgen tests
  =============================
  testncgen.sh: line 113: [: -ne: unary operator expected
  *** test1.cdl   Mon Sep 28 16:55:53 2015
  --- test2.cdl   Mon Sep 28 16:55:53 2015
  ***************
  *** 50,56 ****

     cross =
      4, 5, 0.000244140625,
  !   7, 8, 10000000000 ;

     i = 10, 20 ;

  --- 50,56 ----

     cross =
      4, 5, 0.000244140625,
  !   7, 8, 2147483647 ;

     i = 10, 20 ;

  *** ncgen -b test failed ***
  *** ncgen -c test successful ***
  =============================
  ncgen tests failed: 1
  =============================
Comment 2 Yaakov Selkowitz 2015-12-01 11:18:16 EST
Applies as well to aarch64.  Merging from f22 to epel7 will fix this without a version bump.
Comment 3 Orion Poplawski 2015-12-01 11:23:25 EST
merged and pushed.
Comment 4 Yaakov Selkowitz 2015-12-01 18:04:54 EST
Sorry if I wasn't clear, but did you also make an updated build?
Comment 5 Orion Poplawski 2015-12-01 18:08:02 EST
I did build it, but didn't make an update.
Comment 6 IBM Bug Proxy 2015-12-02 16:10:21 EST
------- Comment From zwilliam@ca.ibm.com 2015-12-02 21:10 EDT-------
I just tested the new SRPM from https://kojipkgs.fedoraproject.org//packages/hdf/4.2.10/7.el7/src/hdf-4.2.10-7.el7.src.rpm. I can build this SRPM on s390x on Mock now. Thank you!
Comment 7 D. Marlin 2016-02-24 18:54:38 EST
Since hdf-4.2.10-7.el7 successfully builds on AArch64 as well, will you please release this as an update for EPEL7?  The build in koji is not tagged:

  http://koji.fedoraproject.org/koji/buildinfo?buildID=702568
Comment 8 Fedora Update System 2016-02-24 22:51:19 EST
hdf-4.2.10-7.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-064495a256
Comment 9 Fedora Update System 2016-02-26 21:20:48 EST
hdf-4.2.10-7.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-064495a256
Comment 10 Fedora Update System 2016-02-28 15:24:26 EST
hdf-4.2.10-7.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.