Bug 1269862 - Dolphin fails to render using X w/o root rights (sudo dolphin displays a blank window)
Dolphin fails to render using X w/o root rights (sudo dolphin displays a blan...
Status: CLOSED DUPLICATE of bug 1236528
Product: Fedora
Classification: Fedora
Component: dolphin (Show other bugs)
22
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Vrátil
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-08 07:28 EDT by Peter Hostačný
Modified: 2016-07-31 21:06 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-08 17:25:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Hostačný 2015-10-08 07:28:36 EDT
Description of problem:
When I try to launch dolphin under root, I get asked for password as normal, then the window shows, but the main pain is just blank/gray. I am using F22 with gnome desktop environment, so maybe it is issue related only for gnome users.

Version-Release number of selected component (if applicable):
Using: GNOME Shell 3.16.3
Qt: 4.8.6
KDE: 4.14.11
Dolphin: 15.04.0

How reproducible:
always

Steps to Reproduce:
1. $ sudo dolphin
or
1. $ su
2. $ dolphin

Actual results:
gray window

Expected results:
normal window displaying dolphin GUI

Workaround:
"QT_GRAPHICSSYSTEM=raster [kdesu|sudo] dolphin"
"QT_GRAPHICSSYSTEM=native [kdesu|sudo] dolphin"

Similar bug:
https://bugzilla.redhat.com/show_bug.cgi?id=1212180
Comment 1 Rex Dieter 2015-10-08 07:44:43 EDT
It's more than just similar, it's the same one.

The workaround is the same, to run qt4 apps as root, set environment variable,

QT_GRAPHICSSYSTEM=native
Comment 2 Kevin Kofler 2015-10-08 17:25:01 EDT

*** This bug has been marked as a duplicate of bug 1236528 ***

Note You need to log in before you can comment on or make changes to this bug.