Bug 1269878 - gnome wayland session: .bash_profile ignored
gnome wayland session: .bash_profile ignored
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-session (Show other bugs)
23
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-08 08:11 EDT by Fabio Valentini
Modified: 2015-11-11 07:30 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-11 07:30:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 736660 None None None Never

  None (edit)
Description Fabio Valentini 2015-10-08 08:11:42 EDT
Steps to Reproduce:

1. log in to GNOME (Wayland)

2. $ cat .bash_profile
# .bash_profile

# Get the aliases and functions
if [ -f ~/.bashrc ]; then
	. ~/.bashrc
fi

# User specific environment and startup programs

PATH=$PATH:$HOME/.local/bin:$HOME/bin

export PATH


3. $ echo $PATH
/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/sbin
Comment 1 Fabio Valentini 2015-11-11 07:00:57 EST
Is there anything happening to find out what causes this bug?
Because it is really annoying.
Comment 2 Ray Strode [halfline] 2015-11-11 07:30:28 EST
We're tracking this upstream here:

https://bugzilla.gnome.org/show_bug.cgi?id=736660

The issue is right now the start up path contains a tower of shell scripts that have nothing to do with the graphical session, and wayland is an opportunity to break away from that.

Obviously we need a way for users to set environment variables, though. See the upstream bug for more details.

Note You need to log in before you can comment on or make changes to this bug.