Bug 1269920 - kpatch-build missing
kpatch-build missing
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kpatch (Show other bugs)
7.0
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Josh Poimboeuf
Chunyu Hu
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-08 09:37 EDT by Jeremy Harris
Modified: 2015-10-12 12:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-12 12:13:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Harris 2015-10-08 09:37:14 EDT
Description of problem:
  Neither the utility nor the manpage for kpatch-build can be found

Version-Release number of selected component (if applicable):


How reproducible:
  100%


Steps to Reproduce:
1. (in a VM) RHEL7 install procedure per https://github.com/dynup/kpatch
2. sudo yum provides */*kpatch-build*
3.

Actual results:
  Loaded plugins: auto-update-debuginfo, langpacks, product-id, subscription-manager
  No matches found



Expected results:
  Usable kpatch installation

Additional info:

  kpatch itself is present, though I don't know if the above sequence installed
it or my original system installation:

  [jgh@rhel7 kpatch]$ which kpatch
  /usr/sbin/kpatch
Comment 2 Seth Jennings 2015-10-08 13:05:21 EDT
There is only a kpatch package for RHEL7, not a kpatch-build package.  There is currently no package in RHEL7 that includes the build-side utilities for kpatch.  The kpatch package only includes the apply-side utilities (i.e. the kpatch command).

In order to run kpatch-build:

1) Clone the github repo

git clone https://github.com/dynup/kpatch.git

2) Follow the README for "Install the dependencies for the "kpatch-build" command" in the RHEL7 section

https://github.com/dynup/kpatch#rhel-7

3) cd kpatch-build/ then invoke the kpatch-build script from there.
Comment 3 Jeremy Harris 2015-10-09 04:10:56 EDT
Those instructions do not appear to be sufficient:

 [jgh@rhel7 kpatch]$ kpatch-build ss.patch 
 ERROR: can't find supporting tools.

For added amusement, the manpage for kpatch references one for kpatch-build.
Comment 4 Josh Poimboeuf 2015-10-12 12:06:36 EDT
Jeremy,

Did you do "make" and "make install" first?
Comment 5 Josh Poimboeuf 2015-10-12 12:13:59 EDT
The missing kpatch-build RPM is by design.  kpatch-build is dangerous and should be used with care.  It isn't intended to be used by RHEL customers.  Any live patching done by customers should only be done with patch modules which have been built and signed internally at Red Hat.

Note You need to log in before you can comment on or make changes to this bug.