Bug 1269933 - [gnome-boxes] existing virtual machines are not always listed
Summary: [gnome-boxes] existing virtual machines are not always listed
Keywords:
Status: CLOSED DUPLICATE of bug 1271183
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-boxes
Version: 23
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Christophe Fergeau
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-08 14:00 UTC by Joachim Frieben
Modified: 2015-12-16 15:57 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-16 15:57:07 UTC
Type: Bug


Attachments (Terms of Use)

Description Joachim Frieben 2015-10-08 14:00:36 UTC
Description of problem:
Upon start-up, gnome-boxes does not always show existing virtual machines. In general, it is sufficient to quit gnome-boxes and to launch it again in order to see the present virtual machines.

Version-Release number of selected component (if applicable):
gnome-boxes-3.18.0-1.fc23

How reproducible:
Sometimes.

Steps to Reproduce:
1. Launch gnome-boxes.

Actual results:
No virtual machines are listed.

Expected results:
All existing virtual machines are listed.

Additional info:
As far as I remember, this is not a new issue and already occurred in previous releases of Fedora.

Comment 1 Joachim Frieben 2015-10-31 15:58:26 UTC
After launching gnome-boxes from the console no VM being displayed, the following message appeared in the console:

    "(gnome-boxes:6059): Boxes-WARNING **: libvirt-broker.vala:117: Unable to open qemu+unix:///session: Cannot write data: Transport endpoint is not connected" .

After restarting gnome-boxes, the existing VM was displayed correctly, and no message was issued.

Comment 2 Richard W.M. Jones 2015-11-12 12:49:53 UTC
I've had this bug open against libvirt for a while: bug 1271183.

Comment 3 Michael Catanzaro 2015-12-16 15:57:07 UTC

*** This bug has been marked as a duplicate of bug 1271183 ***


Note You need to log in before you can comment on or make changes to this bug.