Bug 1269934 - Failed to import VM
Failed to import VM
Status: CLOSED DUPLICATE of bug 1269930
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity urgent
: ovirt-3.6.0-rc3
: 3.6.0
Assigned To: nobody nobody
virt
: AutomationBlocker, Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-08 10:02 EDT by Israel Pinto
Modified: 2016-02-10 14:23 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-09 09:16:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Israel Pinto 2015-10-08 10:02:16 EDT
Description of problem:
Failed to import VM.

Version-Release number of selected component (if applicable):
RHEVM: rhevm-lib-3.6.0-0.18.el6
VDSM: vdsm-4.17.8-1.el7ev

How reproducible:
All the time (manually and on automation test)

Steps to Reproduce:
1. Create new VM 
2. Export VM to export domain
3. Remove VM 
4. Import VM

Note: In automation the vm name is "export_vm" in manual check the vm name is "export_test"

Actual results:
Failed to import VM: "Internal Engine Error" 

Expected results:
Import VM succeeded 

Additional info:

From the engine log it looks like the engine says that the vm exists.
(The remove vm succeed, there is no vm with this name)
Engine log:
2015-10-08 15:10:24,990 ERROR [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (ajp-/127.0.0.1:8702-7) [482b73ae] Correlation ID: vms_syncAction_1c1b246c-bbcb-4d2f, Job ID: be98fefb-769b-4430-9d0a-b79e2a970e8f, Call Stack: null, Custom Event ID: -1, Message: Failed to import Vm export_vm to Data Center golden_env_mixed, Cluster golden_env_mixed_1
2015-10-08 15:10:25,026 INFO  [org.ovirt.engine.core.bll.ImportVmCommand] (ajp-/127.0.0.1:8702-7) [482b73ae] Lock freed to object 'EngineLock:{exclusiveLocks='[export_vm=<VM_NAME, ACTION_TYPE_FAILED_NAME_ALREADY_USED>, 41029e5b-cd0e-498f-ae71-2f897d5c129f=<VM, ACTION_TYPE_FAILED_VM_IS_BEING_IMPORTED$VmName export_vm>]', sharedLocks='[41029e5b-cd0e-498f-ae71-2f897d5c129f=<REMOTE_VM, ACTION_TYPE_FAILED_VM_IS_BEING_IMPORTED$VmName export_vm>]'}'
2015-10-08 15:10:25,027 ERROR [org.ovirt.engine.api.restapi.resource.AbstractBackendResource] (ajp-/127.0.0.1:8702-7) [] Operation Failed: [Internal Engine Error]
Comment 1 Michal Skrivanek 2015-10-09 09:16:21 EDT

*** This bug has been marked as a duplicate of bug 1269930 ***

Note You need to log in before you can comment on or make changes to this bug.