Bug 1269962 - Mismatch between program and library build versions
Mismatch between program and library build versions
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: wxGTK3 (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeremy Newton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-08 11:33 EDT by Robert Tucker
Modified: 2015-11-01 12:08 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-01 12:08:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Tucker 2015-10-08 11:33:59 EDT
Description of problem:

$ LD_LIBRARY_PATH=/usr/local/lib aegisub-3.2
Fatal Error: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1002,wx containers,compatible with 2.8), and your program used 3.0 (wchar_t,compiler with C++ ABI 1008,wx containers,compatible with 2.8).
Aborted (core dumped)


Version-Release number of selected component (if applicable): 3.0.2-9.fc22


How reproducible: Always


Steps to Reproduce:
1. Configure and compile Aegisub
2. Attempt to run it


Actual results: As above

Expected results: Aegisub to start


Additional info:

Similar bugs reported for wxGTK2.8 as Bug 1200611 and Bug 1190971
Comment 1 Jeremy Newton 2015-11-01 09:04:25 EST
I introduced the fixes in both those bugs a while ago, so that doesn't appear to be the problem.

I'm not exactly sure where this error is coming from. I'll have to look further into this. If you have any insight, feel free to post it here.

Also, are you able to test it with this fresh build of wxGTK3 (when it's done)?
http://koji.fedoraproject.org/koji/taskinfo?taskID=11666437

I can push this to updates if a rebuild resolves the issue.
Comment 2 Robert Tucker 2015-11-01 11:58:27 EST
With a new, clean install of Fedora 22 I have been able to configure, compile and run Aegisub without problem. Sorry, I've no idea what the problem was with the old install.

As I recall, on the new install, it worked straight out with Fedora 22 packaged wxBase3 and wxGTK3. (I've since needed to install 2.8 for Audaicty.)

I think this bug can be closed so far as it concerns me currently.
Comment 3 Jeremy Newton 2015-11-01 12:08:05 EST
Sounds good. Let me know if this re-emerges

Note You need to log in before you can comment on or make changes to this bug.