Bug 1269981 - lbaas doesn't monitor state of haproxy process
lbaas doesn't monitor state of haproxy process
Status: CLOSED DUPLICATE of bug 1326224
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron-lbaas (Show other bugs)
6.0 (Juno)
Unspecified Unspecified
high Severity high
: ---
: 6.0 (Juno)
Assigned To: RHOS Maint
Shai Revivo
: Reopened, ZStream
Depends On:
Blocks: 1273812
  Show dependency treegraph
 
Reported: 2015-10-08 13:12 EDT by Jon Thomas
Modified: 2016-06-03 21:21 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-03 21:21:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Thomas 2015-10-08 13:12:33 EDT
Testing lb functionalities and I saw that if I kill haproxy process, or fence corresponding controller node who started haproxy, this lb never will be restarted on other controller nodes or on the same controller node.

On lbaas-agent.log log, if I kill haproxy process I can see logs like this:

2015-09-22 16:42:32.885 20418 WARNING neutron.services.loadbalancer.drivers.haproxy.namespace_driver [-] Error while connecting to stats socket: [Errno 111] ECONNREFUSED
2015-09-22 16:42:42.887 20418 WARNING neutron.services.loadbalancer.drivers.haproxy.namespace_driver [-] Error while connecting to stats socket: [Errno 111] ECONNREFUSED
2015-09-22 16:42:52.887 20418 WARNING neutron.services.loadbalancer.drivers.haproxy.namespace_driver [-] Error while connecting to stats socket: [Errno 111] ECONNREFUSED

Also, all LB status remain up, even after killing haproxy:
# neutron lb-pool-list
+--------------------------------------+----------+----------+-------------+----------+----------------+--------+
| id                                   | name     | provider | lb_method   | protocol | admin_state_up | status |
+--------------------------------------+----------+----------+-------------+----------+----------------+--------+
| 2c7b6eaf-a43b-447c-b88f-7a27fb58ffc9 | lbpool01 | haproxy  | ROUND_ROBIN | HTTP     | True           | ACTIVE |
+--------------------------------------+----------+----------+-------------+----------+----------------+--------+
Comment 2 Assaf Muller 2015-10-08 13:14:07 EDT
Please re-open upstream, there's nothing RDO or OSP specific about this bug.
Comment 3 Assaf Muller 2015-10-08 13:14:58 EDT
Apologies, I didn't know this was coming from a customer.
Comment 11 Nir Yechiel 2016-04-12 05:31:17 EDT
While our strategy is to move to Octavia in compliant with upstream, our current assessment shows that it will take more time to get it mature and ready for production use. 

As a mid-term solution we are aiming to provide a better HA solution for LBaaS v2 using the HAProxy driver. This work is planned for Newton based on these two bugs:

https://bugs.launchpad.net/neutron/+bug/1565511
https://bugs.launchpad.net/neutron/+bug/1565801
Comment 16 Assaf Muller 2016-06-03 21:21:01 EDT

*** This bug has been marked as a duplicate of bug 1326224 ***

Note You need to log in before you can comment on or make changes to this bug.