Bug 1269982 - No events logged in audit logs when the soft-link for the storage domain went missing.
Summary: No events logged in audit logs when the soft-link for the storage domain went...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.4.0
Hardware: All
OS: All
medium
medium
Target Milestone: ovirt-3.6.3
: 3.6.0
Assignee: Idan Shaby
QA Contact: Elad
URL:
Whiteboard:
Depends On: 1271771
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-08 17:12 UTC by Gajanan
Modified: 2019-10-10 10:22 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-09 21:13:58 UTC
oVirt Team: Storage


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
oVirt gerrit 51393 None None None 2016-02-01 14:06:58 UTC
oVirt gerrit 52902 None None None 2016-02-01 14:06:40 UTC
oVirt gerrit 52923 ovirt-3.6.3 MERGED sp: update domain links on state change 2016-02-01 15:35:00 UTC

Description Gajanan 2015-10-08 17:12:58 UTC
Description of problem:

Customer faced issue in the RHEV 3.4 environment. It was noticed when he was not able to add the disk to the vms, it failed with errors as: 

Operation Add-Disk failed to complete. 
Add-Disk operation of volume_Disk1 was initiated on VM volume by admin.

Also customer was not able to create new vms, or start a powered off vms. 

The running vms were running fine, but once shutdown they failed to start again. 

Some messages are as below: 

VM <vm-name> is down. Exit message: Bad volume specification {.... }
Failed to run VM <vm-name> on Host <host-name>
Failed to run VM TVMENG (User: admin). 

Further it was noticed that the soft-link for a storage domain was missing, restoring the same resolved the issue. 

But we do not know why it was lost. And also when it was lost as there are no events triggered or logged when this could have happened, the issue got noticed when customer failed to add a disk to the vm. 

The RHEV-M should report such events otherwise we /customer will not get alert about it.

Comment 2 Allon Mureinik 2015-10-11 09:15:20 UTC
Tal, let's have someone take a look please?

Comment 5 Allon Mureinik 2016-01-13 16:34:53 UTC
Idan/Amit - once bug 1271771 is solved, what's left to do for this one?

Comment 6 Amit Aviram 2016-01-13 17:27:53 UTC
Unfortunately, Since this bug's target release is 4.0.0, I didn't have the chance to get into it yet.

Comment 7 Idan Shaby 2016-02-01 14:04:15 UTC
From looking at the logs, it seems like a very similar case to the one in BZ 1271771 (comment 18), although I can't be sure since the logs from the first time vdsm couldn't find the link to the lost domain are missing.
Anyway, no matter what the cause for losing the link was, patch 51393 has already solved the links refresh issue, so I guess that it would have solved also this one.

Comment 8 Elad 2016-02-23 08:42:35 UTC
Idan, I tested according to the steps you described in https://bugzilla.redhat.com/show_bug.cgi?id=1271771#c18 and verified 1271771 according to it. 
Does that mean I can move this one to verified?

Comment 9 Idan Shaby 2016-02-23 09:10:53 UTC
Yes, please.

Comment 10 Elad 2016-02-23 09:16:56 UTC
From https://bugzilla.redhat.com/show_bug.cgi?id=1271771#c19 ,

The symlink under /rhev/data-center was created after connectivity to the storage got resumed and for both, image created successfully once the domain became accessible.

Verified using:
rhevm-3.6.3.2-0.1.el6.noarch
vdsm-4.17.21-0.el7ev.noarch

Comment 12 errata-xmlrpc 2016-03-09 21:13:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.