Bug 1270011 - Simplestreams test fails: virt-builder: error: the value for the key 'size' is not an integer
Simplestreams test fails: virt-builder: error: the value for the key 'size' i...
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pino Toscano
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-08 14:56 EDT by Richard W.M. Jones
Modified: 2015-10-12 11:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-12 11:10:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2015-10-08 14:56:28 EDT
Description of problem:

This is on Debian (Jessie) i686.  I don't know if the cause
is Debian or i686.

$ make -C builder check TESTS=test-virt-builder-list-simplestreams.sh LIBGUESTFS_DEBUG=1 LIBGUESTFS_TRACE=1
make: Entering directory '/home/rjones/d/libguestfs/builder'
make   debian.xz fedora.xz ubuntu.xz windows.xz fedora.qcow2 fedora.qcow2.xz
make[1]: Entering directory '/home/rjones/d/libguestfs/builder'
make[1]: 'debian.xz' is up to date.
make[1]: 'fedora.xz' is up to date.
make[1]: 'ubuntu.xz' is up to date.
make[1]: 'windows.xz' is up to date.
make[1]: 'fedora.qcow2' is up to date.
make[1]: 'fedora.qcow2.xz' is up to date.
make[1]: Leaving directory '/home/rjones/d/libguestfs/builder'
make  check-TESTS
make[1]: Entering directory '/home/rjones/d/libguestfs/builder'
/home/rjones/d/libguestfs/run --test ./test-virt-builder-list-simplestreams.sh
virt-builder: error: the value for the key 'size' is not an integer

If reporting bugs, run virt-builder with debugging enabled and include the 
complete output:

  virt-builder -v -x [...]
/home/rjones/d/libguestfs/run: command failed with exit code 1
FAIL: test-virt-builder-list-simplestreams.sh

Version-Release number of selected component (if applicable):

libguestfs 1.31.14
libyajl-dev:i386 2.1.0-2
libyajl2:i386    2.1.0-2

How reproducible:

100%

Steps to Reproduce:
1. Run the command shown above.
Comment 1 Pino Toscano 2015-10-12 11:10:03 EDT
(In reply to Richard W.M. Jones from comment #0)
> I don't know if the cause is Debian or i686.

It's i686 -- the issue is a wrong conversion of double values to OCaml.

Fixed with:
https://github.com/libguestfs/libguestfs/commit/753bf99f5c6ba6bdf904968d34ce6537d79e7869
which is libguestfs >= 1.31.17.

Note You need to log in before you can comment on or make changes to this bug.