Bug 1270012 - [epel7s390x] java-dirq SRPM does not build correctly on s390x
[epel7s390x] java-dirq SRPM does not build correctly on s390x
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: java-dirq (Show other bugs)
epel7
s390x Linux
high Severity medium
: ---
: ---
Assigned To: lionel.cons
Fedora Extras Quality Assurance
:
Depends On:
Blocks: epel7s390x
  Show dependency treegraph
 
Reported: 2015-10-08 15:14 EDT by IBM Bug Proxy
Modified: 2015-12-12 14:40 EST (History)
7 users (show)

See Also:
Fixed In Version: java-dirq-1.6-4.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-12 14:23:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
"surefire-reports" for the failed test case (8.60 KB, text/plain)
2015-10-08 15:14 EDT, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 131523 None None None Never

  None (edit)
Description IBM Bug Proxy 2015-10-08 15:14:27 EDT

    
Comment 1 IBM Bug Proxy 2015-10-08 15:14:29 EDT
The EPEL 7 SRPM for java-dirq 
https://dl.fedoraproject.org/pub/epel/7/SRPMS/j/java-dirq-1.4-5.el7.src.rpm
does not build correctly in Mock on s390x.

The test "QueueSimpleTest.purgeMultiDir" fails and bans the RPM from being built. 

-------------------------------------------------------------------------------
Test set: ch.cern.dirq.QueueSimpleTest
-------------------------------------------------------------------------------
Tests run: 15, Failures: 1, Errors: 0, Skipped: 0, Time elapsed: 2.327 sec <<< FAILURE! - in ch.cern.dirq.QueueSimpleTest
purgeMultiDir(ch.cern.dirq.QueueSimpleTest)  Time elapsed: 0.014 sec  <<< FAILURE!
java.lang.AssertionError: null
        at org.junit.Assert.fail(Assert.java:86)
        at org.junit.Assert.assertTrue(Assert.java:41)
        at org.junit.Assert.assertFalse(Assert.java:64)
        at org.junit.Assert.assertFalse(Assert.java:74)
        at ch.cern.dirq.QueueSimpleTest.purgeMultiDir(QueueSimpleTest.java:297)
Comment 2 IBM Bug Proxy 2015-10-08 15:14:35 EDT
Created attachment 1081076 [details]
"surefire-reports" for the failed test case
Comment 3 lionel.cons 2015-11-13 02:06:51 EST
I would love to debug this but, since this is ARM-specific, I would need interactive access to an ARM machine for this. Contact me if you can offer one.
Comment 5 lionel.cons 2015-11-13 05:19:10 EST
I have fixed the problem upstream.
Comment 6 Fedora Update System 2015-11-17 05:25:54 EST
java-dirq-1.6-3.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-7c841160e6
Comment 7 Fedora Update System 2015-11-17 20:20:24 EST
java-dirq-1.6-3.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update java-dirq'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-7c841160e6
Comment 8 Fedora Update System 2015-11-24 06:35:15 EST
java-dirq-1.6-4.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-7c841160e6
Comment 9 Fedora Update System 2015-11-25 19:54:48 EST
java-dirq-1.6-4.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update java-dirq'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-7c841160e6
Comment 10 IBM Bug Proxy 2015-12-02 15:30:37 EST
------- Comment From zwilliam@ca.ibm.com 2015-12-02 20:32 EDT-------
I just tested the new SRPM from https://dl.fedoraproject.org/pub/epel/testing/7/SRPMS/j/java-dirq-1.6-4.el7.src.rpm. I can build this SRPM on s390x on Mock now. Thank you!
Comment 11 Fedora Update System 2015-12-12 14:23:53 EST
java-dirq-1.6-4.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.
Comment 12 IBM Bug Proxy 2015-12-12 14:40:37 EST
------- Comment From zwilliam@ca.ibm.com 2015-12-12 19:42 EDT-------
I just tested https://dl.fedoraproject.org/pub/epel/7/SRPMS/j/java-dirq-1.6-4.el7.src.rpm. The source RPM builds fine on s390x on Mock. Thanks again!

Note You need to log in before you can comment on or make changes to this bug.