Bug 1270022 - Machine import failure
Machine import failure
Status: CLOSED DUPLICATE of bug 1269948
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.6.0
Unspecified Unspecified
urgent Severity urgent
: ovirt-3.6.0-rc3
: 3.6.0
Assigned To: Ala Hino
Aharon Canan
storage
: AutomationBlocker, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-08 16:00 EDT by Anatoly Litovsky
Modified: 2016-02-10 13:09 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-11 15:48:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sosreport (6.63 MB, application/x-xz)
2015-10-08 16:00 EDT, Anatoly Litovsky
no flags Details

  None (edit)
Description Anatoly Litovsky 2015-10-08 16:00:09 EDT
Created attachment 1081092 [details]
sosreport

Description of problem:
Failed to import VM into export storage

Version-Release number of selected component (if applicable):
[root@engine ~]# rpm -qa | ovirt
-bash: ovirt: command not found
[root@engine ~]# rpm -qa | grep ovirt
ovirt-vmconsole-1.0.0-0.0.6.master.el6ev.noarch
ovirt-engine-extension-aaa-jdbc-0.0.0-8.el6ev.noarch
ovirt-vmconsole-proxy-1.0.0-0.0.6.master.el6ev.noarch
rhevm-setup-plugin-ovirt-engine-common-3.6.0-0.18.el6.noarch
rhevm-setup-plugin-ovirt-engine-3.6.0-0.18.el6.noarch
ovirt-host-deploy-java-1.4.0-0.0.5.master.el6ev.noarch
ovirt-host-deploy-1.4.0-0.0.5.master.el6ev.noarch
[root@engine ~]# rpm -qa | grep rhevm
rhevm-extensions-api-impl-3.6.0-0.18.el6.noarch
rhevm-doc-3.6.0-1.el6eng.noarch
rhevm-setup-plugin-websocket-proxy-3.6.0-0.18.el6.noarch
rhevm-branding-rhev-3.6.0-0.0.master.20150924141153.el6ev.noarch
rhevm-backend-3.6.0-0.18.el6.noarch
rhevm-spice-client-x64-cab-3.6-3.el6.noarch
rhevm-setup-3.6.0-0.18.el6.noarch
rhevm-3.6.0-0.18.el6.noarch
rhevm-iso-uploader-3.6.0-1.el6ev.noarch
rhevm-log-collector-3.6.0-1.el6ev.noarch
rhevm-setup-plugin-ovirt-engine-common-3.6.0-0.18.el6.noarch
rhevm-websocket-proxy-3.6.0-0.18.el6.noarch
rhevm-tools-3.6.0-0.18.el6.noarch
rhevm-dbscripts-3.6.0-0.18.el6.noarch
rhevm-restapi-3.6.0-0.18.el6.noarch
rhevm-spice-client-x64-msi-3.6-3.el6.noarch
rhevm-spice-client-x86-cab-3.6-3.el6.noarch
rhevm-setup-plugins-3.6.0-1.el6ev.noarch
rhevm-vmconsole-proxy-helper-3.6.0-0.18.el6.noarch
rhevm-setup-plugin-ovirt-engine-3.6.0-0.18.el6.noarch
rhevm-sdk-python-3.6.0.2-1.el6ev.noarch
rhevm-image-uploader-3.6.0-1.el6ev.noarch
rhevm-cli-3.6.0.0-1.el6ev.noarch
rhevm-lib-3.6.0-0.18.el6.noarch
rhevm-dependencies-3.6.0-0.0.1.master.el6ev.noarch
rhevm-setup-base-3.6.0-0.18.el6.noarch
rhevm-webadmin-portal-3.6.0-0.18.el6.noarch
rhevm-spice-client-x86-msi-3.6-3.el6.noarch
rhevm-userportal-3.6.0-0.18.el6.noarch
rhevm-setup-plugin-vmconsole-proxy-helper-3.6.0-0.18.el6.noarch
rhevm-guest-agent-common-1.0.11-2.el6ev.noarch

VM archive : 
http://ci-web.eng.lab.tlv.redhat.com/jenkins-jobs-data/rhevh-test-vms/centos7.tar.gz

How reproducible:
100%

Steps to Reproduce:
1.Install engine
2.Register rhevh node 
3.Create export storage import VM using ovirt-image-uploader
4. import VM into engine 

Actual results:
vm failed to import 

Expected results:
vm imported into storage

Additional info:
sosreport attached
Comment 1 Sandro Bonazzola 2015-10-09 04:40:09 EDT
var/log/ovirt-engine/ovirt-image-uploader/ovirt-image-uploader-20151008144243.log is empty, so it seems that no error happened while uploading the image.

If you had an issue while uploading it, please run again with --verbose option and attach the new log.

according to
$ grep 7d4983d4 var/log/ovirt-engine/engine.log
2015-10-08 14:48:26,482 INFO  [org.ovirt.engine.core.bll.ImportVmCommand] (ajp-/127.0.0.1:8702-15) [7d4983d4] Lock Acquired to object 'EngineLock:{exclusiveLocks='[9e8437af-b036-4451-8e98-3fe80b77444b=<VM, ACTION_TYPE_FAILED_VM_IS_BEING_IMPORTED$VmName centos7>, centos7=<VM_NAME, ACTION_TYPE_FAILED_NAME_ALREADY_USED>]', sharedLocks='[9e8437af-b036-4451-8e98-3fe80b77444b=<REMOTE_VM, ACTION_TYPE_FAILED_VM_IS_BEING_IMPORTED$VmName centos7>]'}'
2015-10-08 14:48:26,500 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.GetVmsInfoVDSCommand] (ajp-/127.0.0.1:8702-15) [7d4983d4] START, GetVmsInfoVDSCommand( GetVmsInfoVDSCommandParameters:{runAsync='true', storagePoolId='00000001-0001-0001-0001-000000000024', ignoreFailoverLimit='false', storageDomainId='cc4851cd-000c-4af1-b1cc-dd56ffb7a445', vmIdList='null'}), log id: 3d54671a
2015-10-08 14:48:26,526 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.GetVmsInfoVDSCommand] (ajp-/127.0.0.1:8702-15) [7d4983d4] FINISH, GetVmsInfoVDSCommand, log id: 3d54671a
2015-10-08 14:48:26,743 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.GetImagesListVDSCommand] (ajp-/127.0.0.1:8702-15) [7d4983d4] START, GetImagesListVDSCommand( GetImagesListVDSCommandParameters:{runAsync='true', storagePoolId='00000001-0001-0001-0001-000000000024', ignoreFailoverLimit='false', sdUUID='275d8ae2-5849-4812-94ba-e155c3a75634'}), log id: 4f95c8cf
2015-10-08 14:48:26,752 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.GetImagesListVDSCommand] (ajp-/127.0.0.1:8702-15) [7d4983d4] FINISH, GetImagesListVDSCommand, return: [], log id: 4f95c8cf
2015-10-08 14:48:26,753 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.DoesImageExistVDSCommand] (ajp-/127.0.0.1:8702-15) [7d4983d4] START, DoesImageExistVDSCommand( GetImageInfoVDSCommandParameters:{runAsync='true', storagePoolId='00000001-0001-0001-0001-000000000024', ignoreFailoverLimit='false', storageDomainId='cc4851cd-000c-4af1-b1cc-dd56ffb7a445', imageGroupId='ea284943-a3f1-41af-adee-d44230c46e10', imageId='ca79d52c-597a-4ca9-a40d-bbfa275bbd5e'}), log id: 1421c428
2015-10-08 14:48:26,771 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.DoesImageExistVDSCommand] (ajp-/127.0.0.1:8702-15) [7d4983d4] FINISH, DoesImageExistVDSCommand, return: true, log id: 1421c428
2015-10-08 14:48:27,132 ERROR [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (ajp-/127.0.0.1:8702-15) [15f1fc7f] Correlation ID: 7d4983d4, Job ID: 0c3f8521-112c-4b50-aae5-7424e15f0b00, Call Stack: null, Custom Event ID: -1, Message: Failed to import Vm centos7 to Data Center Default, Cluster Default

Looks like the image was correctly on the export domain but failed while moving to data domain.
So it doesn't seems an image uploader issue. Moving to engine / storage for further investigation
Comment 2 Ala Hino 2015-10-11 04:21:03 EDT
Based on following engine log:

2015-10-08 14:48:27,141 INFO  [org.ovirt.engine.core.bll.ImportVmCommand] (ajp-/127.0.0.1:8702-15) [15f1fc7f] Lock freed to object 'EngineLock:{exclusiveLocks='[9e8437af-b036-4451-8e98-3fe80b77444b=<VM, ACTION_TYPE_FAILED_VM_IS_BEING_IMPORTED$VmName centos7>, centos7=<VM_NAME, ACTION_TYPE_FAILED_NAME_ALREADY_USED>]', sharedLocks='[9e8437af-b036-4451-8e98-3fe80b77444b=<REMOTE_VM, ACTION_TYPE_FAILED_VM_IS_BEING_IMPORTED$VmName centos7>]'}'

Looks like vm name "centos7" is already used. Can you please verify this?
Comment 3 Anatoly Litovsky 2015-10-11 05:19:50 EDT
This is the first VM created/imported after a clean install on fresh machine.
there was now other VM's there
Comment 4 Allon Mureinik 2015-10-11 15:14:52 EDT
Ala, is is a duplicate of bug 1269948 ?
Comment 5 Ala Hino 2015-10-11 15:20:33 EDT
It seems so
Comment 6 Allon Mureinik 2015-10-11 15:48:30 EDT
OK, closing.

Tolik/Fabian - you'll have this available in the next build, or right now if you particularly want to build the engine from source.

*** This bug has been marked as a duplicate of bug 1269948 ***

Note You need to log in before you can comment on or make changes to this bug.