This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1270033 - [RDO-Manager] Node inspection fails when changing the default 'inspection_iprange' value in undecloud.conf.
[RDO-Manager] Node inspection fails when changing the default 'inspection_ipr...
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: instack-undercloud (Show other bugs)
unspecified
x86_64 All
high Severity high
: ---
: Liberty
Assigned To: James Slagle
Shai Revivo
:
: 1269606 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-08 16:44 EDT by Omri Hochman
Modified: 2017-06-18 02:02 EDT (History)
4 users (show)

See Also:
Fixed In Version: instack-undercloud-2.1.3-dev225
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-18 02:02:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Omri Hochman 2015-10-08 16:44:04 EDT
[RDO-Manager] Node inspection fails when changing the default 'inspection_iprange' value in undecloud.conf.


Environment:
------------
instack-undercloud-2.1.3-dev224.el7.centos.noarch
instack-0.0.8-dev4.el7.centos.noarch
openstack-ironic-inspector-2.2.1-dev7.el7.centos.noarch
openstack-ironic-common-4.2.1-dev26.el7.centos.noarch
python-ironic-inspector-client-1.2.1-dev6.el7.centos.noarch
python-ironicclient-0.8.2-dev14.el7.centos.noarch


Description:
-------------

(1) In undercloud.conf change the default values of 'inspection_iprange'  
Example:inspection_iprange = 192.168.0.100,192.168.0.120

(2) Attempt to run : openstack baremetal introspection bulk start - 

Results:
---------
the machines fail to boot to PXE and interception fails on timeout  

The reason:
-----------
The value under /etc/ironic-inspector/dnsmasq.conf  remains with the default value -->  dhcp-range=192.0.2.100,192.0.2.120,29
Comment 1 John Trowbridge 2015-10-12 10:16:31 EDT
This was fixed with the switch to puppet.
Comment 2 Ignacio Bravo 2015-10-14 09:03:45 EDT
*** Bug 1269606 has been marked as a duplicate of this bug. ***
Comment 3 Mike McCune 2016-03-28 18:50:27 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 5 Christopher Brown 2017-06-17 15:42:53 EDT
(In reply to John Trowbridge from comment #1)
> This was fixed with the switch to puppet.

So I guess this can be closed then. :)

Note You need to log in before you can comment on or make changes to this bug.