Bug 1270106 - udev rules need to be fixed (obsolete plugdev->uaccess tag)
udev rules need to be fixed (obsolete plugdev->uaccess tag)
Status: CLOSED DUPLICATE of bug 1177996
Product: Fedora
Classification: Fedora
Component: openocd (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jiri Kastner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-08 21:48 EDT by Przemek Klosowski
Modified: 2015-10-12 13:21 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-12 13:21:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
60-openocd.rules file using uaccess tag (3.73 KB, text/plain)
2015-10-08 21:52 EDT, Przemek Klosowski
no flags Details

  None (edit)
Description Przemek Klosowski 2015-10-08 21:48:37 EDT
Description of problem:
openOCD uses the obsolete group mechanism in udev rules: assigns device files to be R/W by group plugdev, which does not exist on Fedora. The correct action is to use systemd session mechanism that tags the devices as 'uaccess', which then creates ACLs enabling R/W for the current logged-in console user. 

The udev rules file needs to be renamed---it has to be ordered before 70-uaccess.rules


Version-Release number of selected component (if applicable):
openocd-0.8.0-6.fc22.x86_64


How reproducible: very


Steps to Reproduce:
1.grep plugdev /usr/lib/udev/rules.d/99-openocd.rules

Actual results: see many rules using plugdev

Expected results: no plugdev use
Comment 1 Przemek Klosowski 2015-10-08 21:51:09 EDT
The fix is simple: replacing the old GROUP/MODE settings with  TAG+="uaccess"
The /usr/lib/udev/rules.d/99-openocd.rules file must be ordered before 70-uaccess.rules, so I propose renaming it to 60-openocd.rules . I enclose the new file, which should be sent upstream.
Comment 2 Przemek Klosowski 2015-10-08 21:52 EDT
Created attachment 1081152 [details]
60-openocd.rules file using uaccess tag
Comment 3 Przemek Klosowski 2015-10-08 21:53:17 EDT
Of course /usr/lib/udev/rules.d/99-openocd.rules needs to be deleted, too.
Comment 4 Przemek Klosowski 2015-10-09 10:38:28 EDT
BTW, I filed a related bug for libsigrok
https://bugzilla.redhat.com/show_bug.cgi?id=1270102
Comment 5 Jiri Kastner 2015-10-12 13:21:43 EDT

*** This bug has been marked as a duplicate of bug 1177996 ***

Note You need to log in before you can comment on or make changes to this bug.