Bug 127012 - Squirrelmail mailbox dir doesn't match Dovecot config
Summary: Squirrelmail mailbox dir doesn't match Dovecot config
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: squirrelmail (Show other bugs)
(Show other bugs)
Version: 2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Warren Togami
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-30 17:23 UTC by Pete Deffendol
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-21 01:46:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pete Deffendol 2004-06-30 17:23:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040626 Firefox/0.9.1

Description of problem:
In /etc/squirrelmail/config.php, the default setting of:

$default_folder_prefix          = 'mail/';

conflicts with Dovecot's setting to place mailbox folders in ~/mail/.
 As a result, Squirrelmail looks in ~/mail/mail for mail folders. 
Shouldn't this line in config.php be set to:

$default_folder_prefix          = '';



Version-Release number of selected component (if applicable):
squirrelmail-1.4.3-1

How reproducible:
Always

Steps to Reproduce:
1. Start Squirrelmail using default configuration

    

Additional info:

Comment 1 Gary Benson 2004-09-08 13:32:42 UTC
Has uw-imap been replaced with Dovecot in Fedora then?

Comment 2 Warren Togami 2004-10-12 02:19:27 UTC
uw-imap has been completely dropped because it is terrible.  dovecot
and cyrus-imapd are two supported IMAP servers provided in FC2+.

This is not something we can easily fix in a correct way.

Comment 3 Warren Togami 2004-10-21 01:46:49 UTC
But I did so anyway.  config_local.php in a NEW install (not upgrade)
is now dovecot compatible by default.  This will be the case for FC3
and RHEL4.  Please test this.

http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/Fedora/RPMS/squirrelmail-1.4.3a-5.noarch.rpm

Comment 4 Pete Deffendol 2004-10-22 17:10:36 UTC
Tested on Fedora Core 2 by removing existing RPM and installing
squirrelmail-1.4.3a-5.noarch.rpm.  Problem solved!


Note You need to log in before you can comment on or make changes to this bug.