Bug 1270134 - ecryptfs cannot mount home directory on login, SELinux preventing
ecryptfs cannot mount home directory on login, SELinux preventing
Status: CLOSED DUPLICATE of bug 1199287
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-09 00:23 EDT by Paul DeStefano
Modified: 2015-11-07 05:06 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-12 08:44:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul DeStefano 2015-10-09 00:23:00 EDT
Description of problem:
I think I have followed good instructions for building eCryptFS home directory and auto-mounting on login, but it does not work on fresh install of F22.  I did this a long time ago (F18?) and it has broken on at least two upgrades, but not F22.  On a fresh install of F22, however, I find yet another regression.

Version-Release number of selected component (if applicable):
selinux-policy-3.13.1-128

How reproducible:
Always.

Steps to Reproduce:
1. Run through published instructions for setting up encrypted home and auto-mount on login (i.e. using ecryptfs-migrate-home).  See bug 1199287, that's exactly the procedure I used.
2. Try to login


Actual results:
3. Home diirectory is not write-able.

Expected results:
Should work as it has for many years.


Additional info:
Long history of breaking after upgrades.  Has policy just never been updated to allow this?  I thought I had removed the local policy and was using the official policy.  Using audit2allow over three iterations produces a workable local policy.
Comment 1 Miroslav Grepl 2015-10-12 08:44:05 EDT

*** This bug has been marked as a duplicate of bug 1199287 ***
Comment 2 Paul DeStefano 2015-11-07 05:06:44 EST
Well, okay, but I happened again immediately after upgrade to F23.  I'll update the other but, but I cannot change the details on that one, so I'm also marking it here, too.

Note You need to log in before you can comment on or make changes to this bug.