Bug 1270149 - [virtio-win][netkvm] Check guest network link status of virtio nic with status=on failed (build 110)
Summary: [virtio-win][netkvm] Check guest network link status of virtio nic with statu...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Yan Vugenfirer
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-09 06:19 UTC by Yu Wang
Modified: 2016-11-04 08:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Clone Of:
Environment:
Last Closed: 2016-11-04 08:49:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2609 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2016-11-03 15:27:12 UTC

Description Yu Wang 2015-10-09 06:19:40 UTC
Check guest network link status of virtio nic with status=on failed (build 110)

Steps to Reproduce:
1 boot up guest with following cli (status=on)

/usr/libexec/qemu-kvm -name win7-32 -enable-kvm -m 2G -smp 4 -uuid ae361e8d-28a4-4e70-8783-bda0d450ce35 -nodefconfig --nodefaults -chardev socket,id=charmonitor,path=/tmp/win7-32,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -drive file=win.raw,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=driver.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -vga qxl -spice disable-ticketing,port=5909 -monitor stdio -qmp tcp:0:4446,server,nowait -netdev tap,script=/etc/qemu-ifup,downscript=/etc/qemu-ifdown,id=hostnet1,vhost=off,queues=4, -device virtio-net-pci,netdev=hostnet1,id=net1,mac=1a:46:0b:ca:bc:8c,bus=pci.0,mq=on,vectors=10,status=on

2.Inside guest, ping out from guest

3.Under qemu monitor, set network link down.
(qemu)set_link net1 off

4.Inside guest, ping out from guest

5.Reboot guest inside
# ctrl+alt+del --> reboot

6.Inside guest, ping out from guest

7.Reboot guest via qemu monitor
(qemu) system_reset

8.Inside guest, ping out from guest

9.Under qemu monitor, set network link up.
(qemu)set_link net1 on

10.Inside guest, ping out from guest


Actual results:

After step 3,the network status is still on, can not ping out
After step 9,the network status is still off and can not ping out

Expected results:
After step 3, the network status is off, can not ping out
After step 9,the network status is on and can ping out


Additional info:

1 All the windows guests hit this issue.
2 build 105 and 7.1.z don't hit this issue, so it is a regression bug.
3 Workaround:
  After step 9, disable/enable this driver on device manager, the network can ping out.
  After step 9, reboot the guest, the network status is on and can ping out.

Comment 2 Yu Wang 2015-12-08 00:26:47 UTC
Reproduced this issue on virtio-win-prewhql-110 version
Verified this issue on virtio-win-prewhql-111 version

Steps same as comment#0

Actual Results:
on virtio-win-prewhql-110 (un-fixed version) version, this issue can be reproduced
on virtio-win-prewhql-111 (fix version), the network status is normally, and can/cannot ping out, no more reproduced

Base on above, this issue has been fixed already.

Comment 3 lijin 2015-12-08 01:57:51 UTC
change status to verified according to comment#2

Comment 6 errata-xmlrpc 2016-11-04 08:49:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2609.html


Note You need to log in before you can comment on or make changes to this bug.