Bug 1270154 - Console: Case sensitive column names in dataset queries on MySQL 5.7
Console: Case sensitive column names in dataset queries on MySQL 5.7
Status: CLOSED DUPLICATE of bug 1268219
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.2.0
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Neus Miras
Jan Hrcek
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-09 02:49 EDT by Jan Hrcek
Modified: 2015-10-13 09:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-13 09:19:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
server.log with exceptions (6.50 MB, text/plain)
2015-10-09 02:49 EDT, Jan Hrcek
no flags Details

  None (edit)
Description Jan Hrcek 2015-10-09 02:49:52 EDT
Created attachment 1081196 [details]
server.log with exceptions

Description of problem:
This is related to bug #1268219.

There are DatasetLookupExceptions when entering task list. server.log is full of error like these:

SELECT COUNT(*) FROM (SELECT * FROM (select  t.activationtime, t.actualowner, t.createdby, t.createdon, t.deploymentid, t.description, t.duedate, t.name, t.parentid, t.priority, t.processid, t.processinstanceid, t.processsessionid, t.status, t.taskid, t.workitemid, oe.id oeid from AuditTaskImpl t, peopleassignments_potowners po, organizationalentity oe where t.id = po.task_id and po.entity_id = oe.id) AS `dbSQL`) AS `dbSQL`
10:47:01,961 ERROR [org.dashbuilder.dataset.backend.exception.ExceptionManager] (http-/127.0.0.1:8080-2) Can't get metadata on specified data set: jbpmHumanTasksWithUser: org.dashbuilder.dataset.exception.DataSetLookupException: Can't get metadata on specified data set: jbpmHumanTasksWithUser


Version-Release number of selected component (if applicable):
BPM Suite 6.2.0 ER3

How reproducible:
Always

Steps to Reproduce:
1. Deploy business-central with MySQL 5.7 as datasource
2. Navigate to task list, try creating an adhoc task.

Actual results:
Column names are case sensitive by default on mysql -> dataset lookup exceptions in task list. 

Expected results:
No exceptions. I think it would be best if the dataset queries contained the same case as the hibernate creates them by default. In this way case insensitive databases would still work + case sensitive would be happy too. What do you think?

Additional info:
Comment 1 Kris Verlaenen 2015-10-13 09:19:25 EDT

*** This bug has been marked as a duplicate of bug 1268219 ***

Note You need to log in before you can comment on or make changes to this bug.