Bug 1270204 - Crash report on system after registering from "Register Now" rhsm-icon
Crash report on system after registering from "Register Now" rhsm-icon
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.2
Unspecified Unspecified
high Severity medium
: rc
: ---
Assigned To: Chris Snyder
John Sefler
: Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-09 05:26 EDT by Rehana
Modified: 2015-11-19 06:51 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 06:51:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rehana 2015-10-09 05:26:14 EDT
Description of problem:

On a unregistered system , wait for the rhsm-icon to appear. Click on the "Register Now" icon , complete the registration process you will observe a full crash report email on the system 

Version-Release number of selected component (if applicable):

subscription-manager: 1.15.9-14.el7
python-rhsm: 1.15.4-5.el7

How reproducible:
3/3

Steps to Reproduce:
1.Click on "register now" icon 
2.Complete the register process from the GUI, ( with auto-attach)
3.After completing the registration process and crash report appeared on the machine

[root@dhcp35-172 ~]# mail
Heirloom Mail version 12.5 7/5/10.  Type ? for help.
"/var/spool/mail/root": 4 messages
>   1 user@localhost.lab.e  Fri Oct  9 13:02  81/2650  "[abrt] full crash report"
    2 user@localhost.lab.e  Fri Oct  9 13:05  81/2650  "[abrt] full crash report"
    3 user@localhost.lab.e  Fri Oct  9 13:29  81/2650  "[abrt] full crash report"
    4 user@localhost.lab.e  Fri Oct  9 14:06  81/2650  "[abrt] full crash report"
& 4
Message  4:
From user@localhost.lab.eng.blr.redhat.com  Fri Oct  9 14:06:00 2015
Return-Path: <user@localhost.lab.eng.blr.redhat.com>
X-Original-To: root@localhost
Delivered-To: root@localhost.lab.eng.blr.redhat.com
Date: Fri, 09 Oct 2015 14:05:59 +0530
From: user@localhost.lab.eng.blr.redhat.com
To: root@localhost.lab.eng.blr.redhat.com
Subject: [abrt] full crash report
User-Agent: Heirloom mailx 12.5 7/5/10
Content-Type: text/plain; charset=us-ascii
Status: RO

time:           Fri 09 Oct 2015 01:02:18 PM IST
cmdline:        /usr/bin/python /usr/sbin/subscription-manager-gui --register
uid:            0 (root)
abrt_version:   2.1.11
event_log:      
executable:     /usr/sbin/subscription-manager-gui
hostname:       dhcp35-172.lab.eng.blr.redhat.com
kernel:         3.10.0-322.el7.x86_64
last_occurrence: 1444379758
pid:            25926
pkg_arch:       x86_64
pkg_epoch:      0
pkg_name:       subscription-manager-gui
pkg_release:    14.el7
pkg_version:    1.15.9
runlevel:       N 5
username:       root

backtrace:
:managergui.py:373:_on_dialog_destroy:AttributeError: 'NoneType' object has no attribute 'set_sensitive'
:
:Traceback (most recent call last):
:  File "/usr/share/rhsm/subscription_manager/gui/managergui.py", line 373, in _on_dialog_destroy
:    widget.set_sensitive(True)
:AttributeError: 'NoneType' object has no attribute 'set_sensitive'
:
:Local variables in innermost frame:
:widget: None
:obj: <Dialog object at 0x245cf00 (GtkDialog at 0x24acfa0)>
:self: <MainWindow object at 0x1bade10 (subscription_manager+gui+managergui+MainWindow at 0x135ce60)>

environ:
:LANG=en_US.UTF-8
:USERHELPER_UID=1000
:TERM=dumb
:SHELL=/bin/bash
:XAUTHORITY=/root/.xauthYvDGGF
:LOGNAME=root
:USER=root
:HOME=/root
:PATH=/usr/sbin:/usr/bin:/sbin:/bin:/root/bin
:DISPLAY=:0

machineid:
:systemd=2b51ad823bed0e0aeb1a8759be61737e
:sosreport_uploader-dmidecode=75b1613aa9a57cff6e0dfdd68a49568073396b7435176835f419009f4ea8a1d7

os_info:
:NAME="Red Hat Enterprise Linux Server"
:VERSION="7.2 (Maipo)"
:ID="rhel"
:ID_LIKE="fedora"
:VERSION_ID="7.2"
:PRETTY_NAME=OpenShift
:ANSI_COLOR="0;31"
:CPE_NAME="cpe:/o:redhat:enterprise_linux:7.2:beta:server"
:HOME_URL="https://www.redhat.com/"
:BUG_REPORT_URL="https://bugzilla.redhat.com/"
:
:REDHAT_BUGZILLA_PRODUCT="Red Hat Enterprise Linux 7"
:REDHAT_BUGZILLA_PRODUCT_VERSION=7.2
:REDHAT_SUPPORT_PRODUCT="Red Hat Enterprise Linux"
:REDHAT_SUPPORT_PRODUCT_VERSION="7.2 Beta"


Actual results:
Observed above mentioned crash report

Expected results:
there shouldnt be any crash report on the system
Additional info:
Comment 1 Barnaby Court 2015-10-09 12:00:02 EDT
A crash report is being generated but it appears that  no functionality of subscription-manager is being blocked. Due to the crash report being generated however this should be fixed as it will generate many customer support calls.
Comment 2 Chris Snyder 2015-10-12 09:36:17 EDT
commit 071bd32f484ba5cf42d197282612365e10933a64
Author: Christopher Snyder <csnyder@redhat.com>
Date:   Fri Oct 9 11:24:01 2015 -0400

    1270204: Crash report no longer sent when widget is none

In master as of the above commit
Comment 4 Sean Toner 2015-10-15 15:18:48 EDT
I saw the same issue as reported here on subscription-manager-1.15.9-14.el7.x86_64

Tested on RHEL-7.2-Snapshot-5.0:

[root@dhcp129-21 ~]# rpm -qa | grep subscription
subscription-manager-initial-setup-addon-1.15.9-15.el7.x86_64
subscription-manager-1.15.9-15.el7.x86_64
subscription-manager-gui-1.15.9-15.el7.x86_64

Waited for the rhsm-icon to appear and clicked the Register button.  I then registered the system when the subman gui appeared as normal.  There was no crash report or any other ABRT error.
Comment 5 errata-xmlrpc 2015-11-19 06:51:18 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2122.html

Note You need to log in before you can comment on or make changes to this bug.