Bug 127022 - FC2 anaconda aborts install
FC2 anaconda aborts install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-30 14:47 EDT by Kevin R. Porter
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-07 14:54:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin R. Porter 2004-06-30 14:47:39 EDT
Description of problem:During a fresh install of released FC2 on a 
dual P-III (Supermicro P3TDE6), the anaconda installer aborts on some 
random package, does not allow any retry of the package, requiring a 
reboot and start from scratch.   All CD's pass the install media 
check 100% every time locally, and these same media have been used to 
install other systems successfully.  Over several install attempts, 
the anaconda abort occurred in a DIFFERENT package each time with no 
repeats, in many cases SUCCESSFULLY installing packages which aborted 
on earlier attempts - each attempt a total reformat of the disk and 
start from scratch.   In each attempt, I examined the alternate-
consoles before OK'ing the reboot and could not see any evidence 
logged on any of them of WHAT caused anaconda to abort on the package.

Version-Release number of selected component (if applicable):Anaconda 
as shipped with released Fedora Core 2.

How reproducible: As noted above, fresh NEW install (including 
erasing all old partitions, repartition and reformat the disk for 
each attempt), have tried graphical install, have also tried text-
only install both work until it starts installing packages, installs 
the first few packages and then at some random package declares a 
fatal error and insists on reboot start over.

Expected results:SHOULD AT THE VERY LEAST PROVIDE SOME DIAGNOSTIC 
INFORMATION AS TO THE NATURE OF THE "FATAL ERROR"!     Transient read 
errors on a CDROM should not be showstoppers, no matter what the 
error "appears" to be, the user should be given the option to RETRY 
the failing package, instead of giving up totally.  


Additional info: System is a dual (SMP) Pentium-III (Tualatin 1.4's), 
Supermicro P3TDE6-G motherboard w/AMI bios 1.2a (latest on Supermicro 
website as this posting), 2gig ECC RAM.    Install is booting from 
Plextor CDRW (secondary master IDE) drive and installing to an 
WD1200JB (primary master IDE) drive.   This system has had previous 
Linux releases installed on it with no difficulty... FC2 is the first 
which has ever stymied me this badly.
Comment 1 Jeremy Katz 2004-06-30 15:09:36 EDT
If you boot with 'ide=nodma' does it help?
Comment 2 Kevin R. Porter 2004-06-30 16:30:48 EDT
Three attempts (booting as "linux ide=nodma") later... three more 
aborts, abort occurred on a different package each time.

Could this be an FC2 versus "dual-PIII's" thing?   Or maybe FC2 
doesn't like the P3TDE6 mobo's IDE controllers?  God knows, I've got 
everything else disabled in the bios.
Comment 3 Kevin R. Porter 2004-07-10 02:13:55 EDT
Tried something different...plugged a SCSI CDRW drive into the 
P3TDE6's onboard SCSI adaptors... and booted FC2 install from there, 
(still installing to primary-master-IDE drive though)... and got all 
the way through the install using the same set of CDR's.

Installing reading from secondary-master-ide CDRW and writing to 
primary-master-ide harddrive experienced random aborts... Installing 
reading from SCSI CDRW and writing to primary-master-ide harddrive 
works.

Note: Was able to do a FreeBSD 5.2.1 install from that same secondary-
master-ide CDRW drive to identical primary-master-ide harddrive 
without difficulties.   (the HD is in a Vantec "drawer" and can be 
swapped to switch O.S. platforms.   Both HD's were identical 
WD1200JB's.)

So got FC2 installed, despite some lingering suspicions that 
something (maybe IDE related) is groaning a bit under very heavy load 
with both primary and secondary IDE controllers active simultaneously.

Comment 4 Jeremy Katz 2004-10-07 14:54:24 EDT
Should be happier with FC3.

Note You need to log in before you can comment on or make changes to this bug.