Bug 1270232 - [RFE] Openstack infra provider node shows green tick status sign while being turned off
[RFE] Openstack infra provider node shows green tick status sign while being ...
Status: CLOSED WONTFIX
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.4.0
Unspecified Unspecified
medium Severity high
: GA
: cfme-future
Assigned To: John Hardy
Ola Pavlenko
openstack
: FutureFeature, ZStream
Depends On:
Blocks: 1290207 1349065
  Show dependency treegraph
 
Reported: 2015-10-09 06:38 EDT by Marius Cornea
Modified: 2017-08-28 10:50 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 1290207 1349065 (view as bug list)
Environment:
Last Closed: 2017-08-28 10:50:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marius Cornea 2015-10-09 06:38:34 EDT
Description of problem:
Openstack infra provider node shows green tick status while being powered off. The node has been used in a previous overcloud deployment when SmartState analysis was also performed. In the current deployment the node is not provisioned(powered off) but CFME still shows data from previous deployment like:
green tick status sign 
properties(ip address, OS, devices, etc)
users/group
packages/services/files
openstack services

Version-Release number of selected component (if applicable):
5.4.3.0.20151001120745_d11cf59

How reproducible:
100%

Steps to Reproduce:
1. Deploy overcloud with 2 compute nodes
2. Performs smart state analysis one all the nodes
3. Delete overcloud
4. Redeploy overcloud with 1 compute node

Actual results:
There is one node that is powered off but shows the green tick status sign.

Expected results:
The additional node would not show the green tick sign and any other data from the previous deployment.
Comment 2 Greg Blomquist 2015-10-12 14:08:18 EDT
Ladas,

can you find out if this is an inventory/smart state problem? Or, if this is a problem in the UI?
Comment 3 Ladislav Smola 2015-11-03 06:30:25 EST
The problem here is that it shows a state obtained from last SSA,  the state could be combined with a state of the machine I guess
Comment 4 Ladislav Smola 2015-11-04 09:06:31 EST
@Greg so this is a normal SSA behaviour.

Problem here is: e.g. you deploy node as compute, do SSA, you have green state and some attributes back.

Now when you delate the node from stack, which will shut it down and it will no longer be compute, there is this behaviour after refresh.
1. The node shows it's stopped in upper right icon, but showk green in down right icon. This doesn't change until you run another SSA. This is how SSA works, do we want to change that somehow? SSA state is not necessarily connected to state of the host, e.g. you can use IPMI or 3rd party APIs to get the attributes. So seems correct to me

2. The attributes that are shown users, groups, files, openstack-status are still shown. Cause the last ssa didn't finish, because it couldn't connect to the host. Meaning we doesn't store blank attributes and drift.

SOLUTION2: Fix for this could be just hide the SSA connected attributes in the UI, when last SSA failed. Or showing how old are the data shown, so timestamp of last drift e.g.

What do you think @greg?

Btw. now, it is similar to how it worked before. Which is when you can't get any SSA data, the drift actually doesn't create a new record nor it deletes the previously filled attributes. Now I just skip it entirely e.g. when hostname is blank
Comment 5 Ladislav Smola 2015-11-06 03:52:18 EST
Can we change this to web UI RFE which would do SOLUTION2 from comment #4?
Comment 6 Greg Blomquist 2016-02-08 09:00:54 EST
@Ladas,

if I'm understanding this correctly, it almost sounds like we should be capturing the status of the last SSA and showing that somewhere.

I added something like that for Last Refresh status a while back.

That might be better than just hiding information based on the last SSA status.

Thoughts?
Comment 7 Ladislav Smola 2016-02-09 05:21:50 EST
@Greg yes. The simple way would be, that we will just show Lifecycle area, which has last analysed info. And probably Analysis History. And the connection of the status and attributes with SSA would be documented,

More complex way would be to show, that the green tick and the SSA attributes they see are tied to the last SSA done. But each provider can have that info different. So e.g. in one provider, that attribute can come from API, but in other provider it comes from SSA. But this is not handled even in VMs. We would need some designer to tell us, what would be the best way, most understandable to user. But we already have some new design of the detail pages?
Comment 8 Greg Blomquist 2016-05-03 13:33:08 EDT
K, so this sounds like an RFE to me.  I'm marking it as such and we can talk to John Hardy about prioritizing.
Comment 13 Chris Pelland 2017-08-28 10:50:18 EDT
This bug has been open for more than a year and is assigned to an older release of CloudForms. 

If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.

Note You need to log in before you can comment on or make changes to this bug.