Bug 1270233 - Heat stack service provisioning shows service provision successful but no stack gets created
Heat stack service provisioning shows service provision successful but no sta...
Status: CLOSED NOTABUG
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Provisioning (Show other bugs)
5.4.0
Unspecified Unspecified
high Severity high
: GA
: 5.5.0
Assigned To: Bill Wei
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-09 06:39 EDT by Aziza Karol
Modified: 2015-11-11 15:17 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-19 16:16:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
catalog item (84.61 KB, image/png)
2015-10-09 06:39 EDT, Aziza Karol
no flags Details
request page (74.12 KB, image/png)
2015-10-09 06:43 EDT, Aziza Karol
no flags Details

  None (edit)
Description Aziza Karol 2015-10-09 06:39:12 EDT
Created attachment 1081266 [details]
catalog item

Description of problem:


Version-Release number of selected component (if applicable):
5.4.3

How reproducible:
100%

Steps to Reproduce:
1.create a service dialog base on heat orchestration template

2.create a catalog item type of orchestration and use the above dialog and select provider openstack. see attached screenshot.
Entrypoint:/Service/Provisioning/StateMachines/ServiceProvision_Template/CatalogItemInitialization

3.order the service

Actual results:
Request page shows Service Provisioned Successfully , but no stack is displayed in stack page

Expected results:
stack should be created

Additional info:
Comment 1 Aziza Karol 2015-10-09 06:43 EDT
Created attachment 1081271 [details]
request page
Comment 4 Bill Wei 2015-10-09 09:37:19 EDT
Aziza,

If you want to provision with a single catalog item, you need to create a catalog item for type Orchestration, the provisioning entry point must be Cloud/Orchestration/Provisioning/StateMachines/Provision/default

If you want to provision with a catalog bundle, you need to 
1. create a catalog item for type Orchestration, the entry point must be
Cloud/Orchestration/Provisioning/StateMachines/Provision/CatalogItemInitialization. Currently I don't see this entry point in your testing environment. Have you used the right version, or have you imported our latest fix that Tina put?
2. create a catalog bundle and include the above catalog item.
Comment 6 Bill Wei 2015-10-12 09:54:16 EDT
Aziza,

The error Fog::Compute::OpenStack::NotFound]: Expected([200] you found was expected. You don't need to worry about it.

Your stack creation has been rolled back. This means your configuration at CFME is correct. The problem is from the provider side. Because the failed stack was rolled back, meaning it was deleted from the provider, we cannot capture the failure reason, nor can we find it during the refresh.

In order to diagnose the reason to fail the creation, you should choose "DO NOTHING" option when you placed the order. This way the failed stack will remain on the provider so we can investigate what caused the failure. Likely it is caused by some invalid parameters given at the ordering time.
Comment 10 Bill Wei 2015-10-19 16:16:35 EDT
According to the latest testing result, a stack had been created on the provider. This showed the CFME stack provisioning functions as designed. The stack status CREATE_FAILED was read from the provider.

Note You need to log in before you can comment on or make changes to this bug.