Bug 1270247 - [abrt] NetworkManager: nm_device_get_unmanaged_flag(): NetworkManager killed by SIGSEGV
Summary: [abrt] NetworkManager: nm_device_get_unmanaged_flag(): NetworkManager killed ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lubomir Rintel
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:a5ce3a2c3bc1be12beca602d9bb...
: 1180827 1298009 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-09 11:41 UTC by Terry Moschou
Modified: 2016-04-03 17:51 UTC (History)
8 users (show)

Fixed In Version: NetworkManager-1.0.12-1.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-03 17:51:05 UTC
thaller: needinfo-


Attachments (Terms of Use)
File: backtrace (18.71 KB, text/plain)
2015-10-09 11:41 UTC, Terry Moschou
no flags Details
File: cgroup (208 bytes, text/plain)
2015-10-09 11:42 UTC, Terry Moschou
no flags Details
File: core_backtrace (6.37 KB, text/plain)
2015-10-09 11:42 UTC, Terry Moschou
no flags Details
File: dso_list (5.67 KB, text/plain)
2015-10-09 11:42 UTC, Terry Moschou
no flags Details
File: environ (72 bytes, text/plain)
2015-10-09 11:42 UTC, Terry Moschou
no flags Details
File: limits (1.29 KB, text/plain)
2015-10-09 11:42 UTC, Terry Moschou
no flags Details
File: maps (27.26 KB, text/plain)
2015-10-09 11:42 UTC, Terry Moschou
no flags Details
File: mountinfo (3.18 KB, text/plain)
2015-10-09 11:42 UTC, Terry Moschou
no flags Details
File: namespaces (85 bytes, text/plain)
2015-10-09 11:42 UTC, Terry Moschou
no flags Details
File: open_fds (2.76 KB, text/plain)
2015-10-09 11:42 UTC, Terry Moschou
no flags Details
File: proc_pid_status (974 bytes, text/plain)
2015-10-09 11:42 UTC, Terry Moschou
no flags Details
File: var_log_messages (13.42 KB, text/plain)
2015-10-09 11:42 UTC, Terry Moschou
no flags Details

Description Terry Moschou 2015-10-09 11:41:54 UTC
Version-Release number of selected component:
NetworkManager-1.0.6-6.fc22

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        /usr/sbin/NetworkManager --no-daemon
crash_function: nm_device_get_unmanaged_flag
executable:     /usr/sbin/NetworkManager
global_pid:     885
kernel:         4.1.8-200.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            0

Truncated backtrace:
Thread no. 1 (5 frames)
 #0 nm_device_get_unmanaged_flag at devices/nm-device.c:7510
 #1 nm_device_get_default_unmanaged at devices/nm-device.c:7522
 #2 _set_state_full at devices/nm-device.c:8559
 #3 nm_device_state_changed at devices/nm-device.c:8692
 #4 queued_set_state at devices/nm-device.c:8716

Potential duplicate: bug 1180827

Comment 1 Terry Moschou 2015-10-09 11:41:59 UTC
Created attachment 1081295 [details]
File: backtrace

Comment 2 Terry Moschou 2015-10-09 11:42:01 UTC
Created attachment 1081296 [details]
File: cgroup

Comment 3 Terry Moschou 2015-10-09 11:42:02 UTC
Created attachment 1081297 [details]
File: core_backtrace

Comment 4 Terry Moschou 2015-10-09 11:42:04 UTC
Created attachment 1081298 [details]
File: dso_list

Comment 5 Terry Moschou 2015-10-09 11:42:06 UTC
Created attachment 1081299 [details]
File: environ

Comment 6 Terry Moschou 2015-10-09 11:42:07 UTC
Created attachment 1081300 [details]
File: limits

Comment 7 Terry Moschou 2015-10-09 11:42:09 UTC
Created attachment 1081301 [details]
File: maps

Comment 8 Terry Moschou 2015-10-09 11:42:11 UTC
Created attachment 1081302 [details]
File: mountinfo

Comment 9 Terry Moschou 2015-10-09 11:42:13 UTC
Created attachment 1081303 [details]
File: namespaces

Comment 10 Terry Moschou 2015-10-09 11:42:14 UTC
Created attachment 1081304 [details]
File: open_fds

Comment 11 Terry Moschou 2015-10-09 11:42:16 UTC
Created attachment 1081305 [details]
File: proc_pid_status

Comment 12 Terry Moschou 2015-10-09 11:42:18 UTC
Created attachment 1081306 [details]
File: var_log_messages

Comment 13 Jirka Klimes 2015-10-09 12:00:47 UTC
*** Bug 1180827 has been marked as a duplicate of this bug. ***

Comment 14 Jirka Klimes 2015-10-09 12:31:24 UTC
Is the crash reproducible? Do you happen to know what you did before it crashed?
It seems to be related to a reactivation of a Wi-Fi connection with a USB dongle.

Comment 15 Thomas Haller 2016-01-19 11:51:33 UTC
*** Bug 1298009 has been marked as a duplicate of this bug. ***

Comment 16 Thomas Haller 2016-01-19 12:17:18 UTC
There are now a few duplicates of this BZ and it also happened on recent NetworkManager-1.0.8-1.fc23 (rh 1298009).


While the cause is unclear to me, I added a patch to upstream which might help to investigate the issue:


master: http://cgit.freedesktop.org/NetworkManager/NetworkManager/commit/?id=76f90812f456dd5dc2bfd12b1d56573a7c65f3d0

nm-1-0: http://cgit.freedesktop.org/NetworkManager/NetworkManager/commit/?id=baefcdbade1c8d9aef1d88144772c8ea995546e9

Comment 17 Fedora Update System 2016-04-02 05:25:37 UTC
NetworkManager-1.0.12-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-8201e3fefa

Comment 18 Fedora Update System 2016-04-03 17:50:49 UTC
NetworkManager-1.0.12-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.