Bug 127025 - perl-5.8.4-3: strip warnings
perl-5.8.4-3: strip warnings
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Turner
David Lawrence
: EasyFix, Patch
Depends On:
Blocks: FC4Blocker
  Show dependency treegraph
 
Reported: 2004-06-30 15:18 EDT by Jose Pedro Oliveira
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-29 16:45:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix against current CVS devel (566 bytes, patch)
2005-01-29 09:34 EST, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Jose Pedro Oliveira 2004-06-30 15:18:33 EDT
Description of problem:
Building perl with a non-root account generates a lot warnings
during the stripping process.

Version-Release number of selected component (if applicable):
perl-5.8.4-3

How reproducible:
Always.


Steps to Reproduce:
Normal building procedures (rpmbuild -ba perl.spec)
  
Actual results:
...
/usr/bin/strip: unable to copy file
'/var/tmp/perl-root/usr/lib/perl5/5.8.4/i386-linux-thread-multi/auto/DynaLoader/DynaLoader.a'
reason: Permission denied
+ /usr/lib/rpm/redhat/brp-strip-comment-note /usr/bin/strip
/usr/bin/objdump
/usr/bin/strip: unable to copy file
'/var/tmp/perl-root/usr/lib/perl5/5.8.4/i386-linux-thread-multi/CORE/libperl.so'
reason: Permission denied
/usr/bin/strip: unable to copy file
'/var/tmp/perl-root/usr/lib/perl5/5.8.4/i386-linux-thread-multi/auto/File/Glob/Glob.so'
reason: Permission denied

   (several lines reporting the same problem were deleted)

...

Expected results:
No warnings.

Additional info:
Adding the line 

    chmod -R u+w $RPM_BUILD_ROOT/*

at the end of the install section resolves the problem.
Note: This line is recommended by fedora.us for perl related specfiles.
Comment 1 Ville Skyttä 2005-01-29 09:34:25 EST
Created attachment 110380 [details]
Fix against current CVS devel

The changelog entry for this bug has been applied from bug 120772, but the
actual fix has not.  The attachment (against current CVS devel) fixes it.

This is no longer a big deal because find-debuginfo.sh can temporarily "chmod
+w" unwritable files during build, but would be nice to have applied so that
the file perms are consistent with the rest of the world, and things would work
if someone rebuilds this using an older version of rpm where the
find-debuginfo.sh workaround is not yet available.
Comment 2 Warren Togami 2005-01-29 16:45:07 EST
Applied to FC4.

Note You need to log in before you can comment on or make changes to this bug.