Bug 1270267 - perl-Sys-Syscall SRPM does not build correctly on aarch64/ppc64le/s390x
perl-Sys-Syscall SRPM does not build correctly on aarch64/ppc64le/s390x
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: perl-Sys-Syscall (Show other bugs)
epel7
s390x Linux
high Severity medium
: ---
: ---
Assigned To: Petr Šabata
Fedora Extras Quality Assurance
:
Depends On: 1288335
Blocks: epel7ppc64le epel7s390x epel7aarch64
  Show dependency treegraph
 
Reported: 2015-10-09 09:02 EDT by IBM Bug Proxy
Modified: 2016-04-27 22:04 EDT (History)
7 users (show)

See Also:
Fixed In Version: perl-Sys-Syscall-0.25-10.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-27 22:04:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Build Log (14.20 KB, text/plain)
2015-10-09 09:02 EDT, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 131554 None None None Never

  None (edit)
Description IBM Bug Proxy 2015-10-09 09:02:03 EDT

    
Comment 1 IBM Bug Proxy 2015-10-09 09:02:06 EDT
The EPEL 7 SRPM for perl-Sys-Syscall 
https://dl.fedoraproject.org/pub/epel/7/SRPMS/p/perl-Sys-Syscall-0.25-2.el7.src.rpm
does not build correctly in Mock on s390x.

The failure is caused but a test program failing. The error message is below:

+ make test
PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/00-use.t ....... ok

#   Failed test 'event is stdout'
#   at t/01-epoll.t line 39.
#          got: '0'
#     expected: '4'
# listening on 55486 and 47842

#   Failed test 'got both'
#   at t/01-epoll.t line 80.
# Looks like you failed 2 tests of 20.
t/01-epoll.t .....
Dubious, test returned 2 (wstat 512, 0x200)
Failed 2/20 subtests
t/02-sendfile.t .. ok

Test Summary Report
-------------------
t/01-epoll.t   (Wstat: 512 Tests: 20 Failed: 2)
  Failed tests:  8, 18
  Non-zero exit status: 2
Files=3, Tests=23,  2 wallclock secs ( 0.02 usr  0.01 sys +  0.13 cusr  0.02 csys =  0.18 CPU)
Result: FAIL
Failed 1/3 test programs. 2/23 subtests failed.
make: *** [test_dynamic] Error 255

Both require the use of epoll_wait which could be the root cause.
Comment 2 IBM Bug Proxy 2015-10-09 09:02:10 EDT
Created attachment 1081330 [details]
Build Log
Comment 3 Yaakov Selkowitz 2015-12-03 23:13:23 EST
This also affects ppc64le and aarch64, and applies to all three arches in Fedora as well.  I'm working on a patch, but as the Fedora and EPEL packages have different maintainers, I'll file a separate bug for Fedora with the intention of getting that merged into epel7.
Comment 5 Petr Šabata 2015-12-08 12:00:37 EST
I'll push the change here as well.
Comment 6 Fedora Update System 2015-12-08 12:06:01 EST
perl-Sys-Syscall-0.25-10.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-946b5fa65c
Comment 7 IBM Bug Proxy 2015-12-08 14:26:47 EST
------- Comment From zamsaad@ca.ibm.com 2015-12-08 19:21 EDT-------
Tested building perl-Sys-Syscall-0.25-10 (https://kojipkgs.fedoraproject.org//packages/perl-Sys-Syscall/0.25/10.el7/src/perl-Sys-Syscall-0.25-10.el7.src.rpm).

Package built successfully in Mock on s390x.
Comment 8 Fedora Update System 2015-12-09 00:20:30 EST
perl-Sys-Syscall-0.25-10.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update perl-Sys-Syscall'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-946b5fa65c
Comment 9 Fedora Update System 2015-12-26 18:24:08 EST
perl-Sys-Syscall-0.25-10.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.
Comment 10 Yaakov Selkowitz 2016-04-27 22:04:25 EDT
(In reply to Fedora Update System from comment #9)
> perl-Sys-Syscall-0.25-10.el7 has been pushed to the Fedora EPEL 7 stable
> repository. If problems still persist, please make note of it in this bug
> report.

This should have closed the bug but didn't; closing.

Note You need to log in before you can comment on or make changes to this bug.