Bug 1270273 - [abrt] x2goclient: ssh_poll_ctx_remove(): x2goclient killed by SIGSEGV
[abrt] x2goclient: ssh_poll_ctx_remove(): x2goclient killed by SIGSEGV
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: x2goclient (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:211f1db5d781a6371b0efac2d7b...
:
: 1294212 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-09 09:11 EDT by Oliver Sampson
Modified: 2016-07-21 06:25 EDT (History)
7 users (show)

See Also:
Fixed In Version: x2goclient-4.0.5.1-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-05 10:18:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (46.69 KB, text/plain)
2015-10-09 09:11 EDT, Oliver Sampson
no flags Details
File: cgroup (190 bytes, text/plain)
2015-10-09 09:11 EDT, Oliver Sampson
no flags Details
File: core_backtrace (16.18 KB, text/plain)
2015-10-09 09:11 EDT, Oliver Sampson
no flags Details
File: dso_list (13.24 KB, text/plain)
2015-10-09 09:11 EDT, Oliver Sampson
no flags Details
File: environ (1.57 KB, text/plain)
2015-10-09 09:11 EDT, Oliver Sampson
no flags Details
File: limits (1.29 KB, text/plain)
2015-10-09 09:11 EDT, Oliver Sampson
no flags Details
File: maps (68.19 KB, text/plain)
2015-10-09 09:12 EDT, Oliver Sampson
no flags Details
File: mountinfo (3.26 KB, text/plain)
2015-10-09 09:12 EDT, Oliver Sampson
no flags Details
File: namespaces (85 bytes, text/plain)
2015-10-09 09:12 EDT, Oliver Sampson
no flags Details
File: open_fds (1.04 KB, text/plain)
2015-10-09 09:12 EDT, Oliver Sampson
no flags Details
File: proc_pid_status (1015 bytes, text/plain)
2015-10-09 09:12 EDT, Oliver Sampson
no flags Details
File: var_log_messages (28 bytes, text/plain)
2015-10-09 09:12 EDT, Oliver Sampson
no flags Details

  None (edit)
Description Oliver Sampson 2015-10-09 09:11:49 EDT
Description of problem:
After opening a session using the auto-login for the first time, and then closing the session, the error appeared.

Version-Release number of selected component:
x2goclient-4.0.5.0-2.fc22

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        /bin/x2goclient -session 1032924d28f2ac000144136623600000046370014_1444142739_821408
crash_function: ssh_poll_ctx_remove
executable:     /usr/bin/x2goclient
global_pid:     1811
kernel:         4.1.8-200.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 ssh_poll_ctx_remove at /usr/src/debug/libssh-0.7.1/src/poll.c:564
 #1 ssh_poll_free at /usr/src/debug/libssh-0.7.1/src/poll.c:311
 #2 ssh_socket_close at /usr/src/debug/libssh-0.7.1/src/socket.c:447
 #3 ssh_client_connection_callback at /usr/src/debug/libssh-0.7.1/src/client.c:436
 #4 ssh_socket_nonblocking_flush at /usr/src/debug/libssh-0.7.1/src/socket.c:641
 #5 ssh_socket_write at /usr/src/debug/libssh-0.7.1/src/socket.c:622
 #6 ssh_packet_write at /usr/src/debug/libssh-0.7.1/src/packet.c:509
 #7 packet_send2 at /usr/src/debug/libssh-0.7.1/src/packet.c:579
 #8 packet_send at /usr/src/debug/libssh-0.7.1/src/packet.c:604
 #9 channel_open at /usr/src/debug/libssh-0.7.1/src/channels.c:296
Comment 1 Oliver Sampson 2015-10-09 09:11:53 EDT
Created attachment 1081334 [details]
File: backtrace
Comment 2 Oliver Sampson 2015-10-09 09:11:54 EDT
Created attachment 1081335 [details]
File: cgroup
Comment 3 Oliver Sampson 2015-10-09 09:11:56 EDT
Created attachment 1081336 [details]
File: core_backtrace
Comment 4 Oliver Sampson 2015-10-09 09:11:57 EDT
Created attachment 1081337 [details]
File: dso_list
Comment 5 Oliver Sampson 2015-10-09 09:11:58 EDT
Created attachment 1081338 [details]
File: environ
Comment 6 Oliver Sampson 2015-10-09 09:11:59 EDT
Created attachment 1081339 [details]
File: limits
Comment 7 Oliver Sampson 2015-10-09 09:12:01 EDT
Created attachment 1081340 [details]
File: maps
Comment 8 Oliver Sampson 2015-10-09 09:12:03 EDT
Created attachment 1081341 [details]
File: mountinfo
Comment 9 Oliver Sampson 2015-10-09 09:12:04 EDT
Created attachment 1081342 [details]
File: namespaces
Comment 10 Oliver Sampson 2015-10-09 09:12:05 EDT
Created attachment 1081343 [details]
File: open_fds
Comment 11 Oliver Sampson 2015-10-09 09:12:06 EDT
Created attachment 1081344 [details]
File: proc_pid_status
Comment 12 Oliver Sampson 2015-10-09 09:12:07 EDT
Created attachment 1081345 [details]
File: var_log_messages
Comment 13 Orion Poplawski 2015-10-09 11:11:37 EDT
Can you try libssh 0.7.2 from updates testing?
Comment 14 Orion Poplawski 2015-12-28 14:22:29 EST
*** Bug 1294212 has been marked as a duplicate of this bug. ***
Comment 15 Stuart D Gathman 2015-12-30 20:57:23 EST
Another user experienced a similar problem:

Told remote system to reboot.  Suspended x2goclient.  x2goclient went into a CPU loop.  Closing it caused the fault.

reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        x2goclient
crash_function: ssh_poll_ctx_remove
executable:     /usr/bin/x2goclient
global_pid:     31030
kernel:         4.2.7-200.fc22.i686
package:        x2goclient-4.0.5.0-3.fc22
reason:         x2goclient killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 16 Stuart D Gathman 2015-12-30 20:59:00 EST
The above was with libssh-0.7.2-2.fc22.i686
Comment 17 davestux 2016-01-19 17:42:57 EST
Another user experienced a similar problem:

Since updating the system few days ago x2goclient dies immediately after connecting.

reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        x2goclient
crash_function: ssh_poll_ctx_remove
executable:     /usr/bin/x2goclient
global_pid:     27594
kernel:         4.3.3-300.fc23.x86_64
package:        x2goclient-4.0.5.0-3.fc23
reason:         x2goclient killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 18 Orion Poplawski 2016-03-24 18:35:25 EDT
Can you still reproduce this with https://bodhi.fedoraproject.org/updates/FEDORA-2016-06de180216 ?
Comment 19 Fedora Update System 2016-03-26 10:50:40 EDT
x2goclient-4.0.5.1-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-06de180216
Comment 20 Fedora Update System 2016-04-05 10:17:59 EDT
x2goclient-4.0.5.1-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 21 Oliver Sampson 2016-07-21 06:25:07 EDT
Similar problem has been detected:

I executed pkill -u in the remote session, and x2go-client crashed.

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        /usr/bin/x2goclient -session 1032924d28f2ac000146252694800000126200095_1469002457_865317
crash_function: ssh_poll_ctx_remove
executable:     /usr/bin/x2goclient
global_pid:     2151
kernel:         4.6.4-201.fc23.x86_64
package:        x2goclient-4.0.5.1-1.fc23
reason:         x2goclient killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000

Note You need to log in before you can comment on or make changes to this bug.