Bug 1270291 - [epel7s390x] php-pecl-solr2 SRPM does not build correctly on s390x
[epel7s390x] php-pecl-solr2 SRPM does not build correctly on s390x
Status: CLOSED CURRENTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: php-pecl-solr2 (Show other bugs)
epel7
s390x Linux
high Severity medium
: ---
: ---
Assigned To: Remi Collet
Fedora Extras Quality Assurance
:
Depends On:
Blocks: epel7s390x
  Show dependency treegraph
 
Reported: 2015-10-09 10:13 EDT by IBM Bug Proxy
Modified: 2015-12-02 12:20 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-02 12:20:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
php-pecl-solr2 build log (63.95 KB, text/plain)
2015-10-09 10:13 EDT, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 131556 None None None Never

  None (edit)
Description IBM Bug Proxy 2015-10-09 10:13:16 EDT

    
Comment 1 IBM Bug Proxy 2015-10-09 10:13:18 EDT
The EPEL 7 SRPM for php-pecl-solr2 
https://dl.fedoraproject.org/pub/epel/7/SRPMS/p/php-pecl-solr2-2.1.0-1.el7.src.rpm
does not build correctly in Mock on s390x.

Build fails due to a singular test program, does not specify reason or line number.

FAIL SolrUtils::escapeQueryChars() - Testing Lucene Reserved Characters [tests/080.solrutils_escapequerychars.phpt]
Comment 2 IBM Bug Proxy 2015-10-09 10:13:22 EDT
Created attachment 1081350 [details]
php-pecl-solr2 build log
Comment 3 Remi Collet 2015-10-09 10:24:28 EDT
Please version 2.2.0-2 in epel-testing which have some "bigendian" fix.
Comment 4 Remi Collet 2015-12-02 04:22:47 EST
@joseph: can you check with 2.3.0 ?
Comment 5 IBM Bug Proxy 2015-12-02 12:10:58 EST
------- Comment From hannsj_uhl@de.ibm.com 2015-12-02 17:07 EDT-------
Comment from  Mohammad Zaman 2015-12-02 11:57:19 EST

Tested with php-pecl-solr2-2.3.0-1.el7.src.rpm. Package built successfully.
Comment 6 Remi Collet 2015-12-02 12:20:02 EST
Fixed, so I close

Note You need to log in before you can comment on or make changes to this bug.