Bug 1270298 - [epel7s390x] python-mutagen SRPM does not build correctly on s390x
[epel7s390x] python-mutagen SRPM does not build correctly on s390x
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: python-mutagen (Show other bugs)
epel7
s390x Linux
high Severity medium
: ---
: ---
Assigned To: Michele Baldessari
Fedora Extras Quality Assurance
:
Depends On:
Blocks: epel7s390x
  Show dependency treegraph
 
Reported: 2015-10-09 10:23 EDT by IBM Bug Proxy
Modified: 2016-02-10 16:25 EST (History)
7 users (show)

See Also:
Fixed In Version: python-mutagen-1.31-4.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-10 16:25:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
python-mutagen build log (32.39 KB, text/plain)
2015-10-09 10:23 EDT, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 131558 None None None Never

  None (edit)
Description IBM Bug Proxy 2015-10-09 10:23:21 EDT

    
Comment 1 IBM Bug Proxy 2015-10-09 10:23:24 EDT
The EPEL 7 SRPM for python-mutagen 
https://dl.fedoraproject.org/pub/epel/7/SRPMS/p/python-mutagen-1.27-1.el7.src.rpm
does not build correctly in Mock on s390x

The error message when trying to build using Mock:

FAIL: test_synchronizedtextspec (tests.test__id3specs.SpecSanityChecks)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/builddir/build/BUILD/mutagen-1.27/tests/test__id3specs.py", line 92, in test_synchronizedtextspec
    s.write(f, [(u"A", 100)]), b"\xff\xfeA\x00\x00\x00\x00\x00\x00d")
AssertionError: '\xfe\xff\x00A\x00\x00\x00\x00\x00d' != '\xff\xfeA\x00\x00\x00\x00\x00\x00d'		
]
Comment 2 IBM Bug Proxy 2015-10-09 10:23:29 EDT
Created attachment 1081361 [details]
python-mutagen build log
Comment 3 Michele Baldessari 2015-11-26 03:55:54 EST
Filed upstream as well in order to not lose track of this:
https://bitbucket.org/lazka/mutagen/issues/247/test_synchronizedtextspec-fails-on-s390x
Comment 4 Dan Horák 2015-11-26 05:57:39 EST
And it wasn't discovered earlier, because secondary arches just import the noarch build. So I guess it will fail the same way on ppc64 (aka big endian issue).
Comment 5 Fedora Update System 2015-11-28 11:45:25 EST
python-mutagen-1.31-4.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-ab24a6003f
Comment 6 Fedora Update System 2015-11-29 01:52:44 EST
python-mutagen-1.31-4.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update python-mutagen'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-ab24a6003f
Comment 7 IBM Bug Proxy 2015-12-03 03:41:39 EST
------- Comment From hannsj_uhl@de.ibm.com 2015-12-03 08:41 EDT-------
Comment from  Mohammad Zaman 2015-12-02 14:55:00 EST

Tested using python-mutagen-1.31-4.el7.src.rpm from:
https://dl.fedoraproject.org/pub/epel/testing/7/SRPMS/p/python-mutagen-1.31-4.el7.src.rpm

Package built successfully.
Comment 8 Fedora Update System 2016-02-10 16:25:44 EST
python-mutagen-1.31-4.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.