Bug 1270299 - [epel7s390x] py4j SRPM does not build correctly on s390x
[epel7s390x] py4j SRPM does not build correctly on s390x
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: py4j (Show other bugs)
epel7
s390x Linux
low Severity low
: ---
: ---
Assigned To: Raphael Groner
Fedora Extras Quality Assurance
:
Depends On:
Blocks: epel7s390x
  Show dependency treegraph
 
Reported: 2015-10-09 10:23 EDT by IBM Bug Proxy
Modified: 2016-01-30 23:33 EST (History)
6 users (show)

See Also:
Fixed In Version: py4j-0.9.1-1.fc23 py4j-0.9.1-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-23 22:33:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
py4j Build Log (28.55 KB, text/plain)
2015-10-09 10:23 EDT, IBM Bug Proxy
no flags Details
py4j Build Log (16.04 KB, text/plain)
2016-01-14 08:11 EST, IBM Bug Proxy
no flags Details
py4j Build Log (16.04 KB, text/plain)
2016-01-14 08:20 EST, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 131557 None None None Never

  None (edit)
Description IBM Bug Proxy 2015-10-09 10:23:32 EDT

    
Comment 1 IBM Bug Proxy 2015-10-09 10:23:33 EDT
The EPEL 7 SRPM for py4j 
https://dl.fedoraproject.org/pub/epel/7/SRPMS/p/py4j-0.9-0.5.pre.20150720git1cda77a.el7.src.rpm
does not build correctly in Mock.

The failure is caused by the following test program:

    [junit] Testcase: testConnection(py4j.EchoServerTest):      FAILED
    [junit] expected:<[null]
    [junit] > but was:<[yi7]
    [junit] >
    [junit] junit.framework.AssertionFailedError: expected:<[null]
    [junit] > but was:<[yi7]
    [junit] >
    [junit]     at py4j.EchoServerTest.testConnection(EchoServerTest.java:75)
    [junit]
    [junit]
    [junit] Received temp: null

BUILD FAILED
/builddir/build/BUILD/py4j-d9a950dd80ab3e6426ef0cd254f933109dddd9e5/py4j-java/build.xml:132: Test py4j.EchoServerTest failed
Comment 2 IBM Bug Proxy 2015-10-09 10:23:39 EDT
Created attachment 1081362 [details]
py4j Build Log
Comment 3 Raphael Groner 2015-10-09 13:47:42 EDT
Thanks for your report. 

As s390x is no primary architecture of EPEL7 and I do not know if upstream cares really about s390x compatibility as well as all the tests pass with BuildArch: noarch for a normal build in Fedora [1], I can not confirm the priority set to high. Also I do not own any s390x hardware to reproduce the failing build.

Though, I would be happy to include a patch or if someone pokes upstream. Another alternative could be to use ExcludeArch: s390x. Please decide and tell me what solution is appropriate.

[1] http://koji.fedoraproject.org/koji/buildinfo?buildID=670628
Comment 4 Raphael Groner 2015-12-17 14:39:47 EST
Ping?
Comment 5 Dan Horák 2015-12-17 14:55:18 EST
pong :-)

Very likely it's not an EPEL specific issue, but it is hidden in Fedora because we directly import all fully noarch builds. So it can exist also on ppc64/ppc64le or aarch64. Access to a Fedora s390x system can be provided. Please keep the bug open until a correct solution is found.
Comment 6 Raphael Groner 2015-12-17 17:53:47 EST
Please retry with py4j-0.9-1.el7
Comment 7 Fedora Update System 2016-01-14 05:47:24 EST
py4j-0.9.1-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-cf6348e0b5
Comment 8 Fedora Update System 2016-01-14 05:47:26 EST
py4j-0.9.1-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-bbdc9cff01
Comment 9 IBM Bug Proxy 2016-01-14 08:11:07 EST
Created attachment 1114798 [details]
py4j Build Log
Comment 10 IBM Bug Proxy 2016-01-14 08:20:44 EST
Created attachment 1114799 [details]
py4j Build Log
Comment 11 Raphael Groner 2016-01-14 09:14:37 EST
What to do with a html login page as in the attachment?
Comment 12 Raphael Groner 2016-01-14 09:16:27 EST
http://bugzilla.linux.ibm.com/show_bug.cgi?id=131557

404 Page not found
Comment 13 Hanns-Joachim Uhl 2016-01-14 09:25:34 EST
(In reply to Raphael Groner from comment #11)
> What to do with a html login page as in the attachment?
.
... this attachment can be ignored ... sorry for the noise ...
Comment 14 Fedora Update System 2016-01-15 04:22:57 EST
py4j-0.9.1-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-cf6348e0b5
Comment 15 Fedora Update System 2016-01-15 13:54:25 EST
py4j-0.9.1-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-bbdc9cff01
Comment 16 Fedora Update System 2016-01-23 22:33:03 EST
py4j-0.9.1-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2016-01-30 23:32:57 EST
py4j-0.9.1-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.