Bug 1270332 - Update translations from https://www.transifex.com/lennart/avahi/content/
Update translations from https://www.transifex.com/lennart/avahi/content/
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: avahi (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-09 12:35 EDT by Robert Antoni Buj Gelonch
Modified: 2016-01-28 13:21 EST (History)
4 users (show)

See Also:
Fixed In Version: avahi-0.6.32-0.4.rc.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-28 13:21:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for updating translations (701.59 KB, patch)
2015-10-09 12:35 EDT, Robert Antoni Buj Gelonch
no flags Details | Diff
patch for updating translations v2 (553.29 KB, patch)
2015-10-09 15:34 EDT, Robert Antoni Buj Gelonch
no flags Details | Diff
patch for updating translations v3 (554.34 KB, patch)
2015-10-10 06:07 EDT, Robert Antoni Buj Gelonch
no flags Details | Diff

  None (edit)
Description Robert Antoni Buj Gelonch 2015-10-09 12:35:06 EDT
Created attachment 1081390 [details]
patch for updating translations

fedpkg clone -a -B avahi
cd avahi/f23
fedpkg prep
cp -rp avahi-0.6.31 avahi-0.6.31p
cd avahi-0.6.31p
mkdir .tx
cat << EOF > .tx/config
[main]
host = https://www.transifex.com

[avahi.master-tx-po-avahi-pot]
file_filter = po/<lang>.po
source_file = po/avahi.pot
source_lang = en
EOF
tx pull -fas
sed -i 's/An unexpected D-Bus error occured/An unexpected D-Bus error occurred/g' po/*.po po/*.pot
cd po
ls | sed -n 's/\.po$//p' > LINGUAS
cd ..
cd ..
diff -urN avahi-0.6.31 avahi-0.6.31p > 0009-update-tanslations.patch
diff -uN avahi.spec.ori avahi.spec
--- avahi.spec.ori	2015-10-09 18:03:39.112588405 +0200
+++ avahi.spec	2015-10-09 18:01:43.661728097 +0200
@@ -79,6 +79,7 @@
 # munged a bit to make it apply against tarball
 Patch7:           0007-avahi-common-typo-fix.patch
 Patch8:           0008-avahi-daemon-add-option-host-name-from-machine-id.patch
+Patch9:           0009-update-tanslations.patch
 
 Patch100:         avahi-0.6.30-mono-libdir.patch
 
@@ -371,6 +372,7 @@
 %patch6 -p1 -b .0006
 %patch7 -p1 -b .0007
 %patch8 -p1 -b .0008
+%patch9 -p1 -b .0009
 
 %patch100 -p1 -b .mono-libdir
 %patch101 -p1 -b .no_deprecations
Comment 1 Robert Antoni Buj Gelonch 2015-10-09 15:23:58 EDT
-1 WIP: apply the patch at the end after updating pot & po files
Comment 2 Robert Antoni Buj Gelonch 2015-10-09 15:34:03 EDT
fedpkg clone -a -B avahi
cd avahi/f23
fedpkg prep
cp -rp avahi-0.6.31 avahi-0.6.31p
cd avahi-0.6.31p
mkdir .tx
cat << EOF > .tx/config
[main]
host = https://www.transifex.com

[avahi.master-tx-po-avahi-pot]
file_filter = po/<lang>.po
source_file = po/avahi.pot
source_lang = en
EOF
tx pull -fas
sed -i 's/An unexpected D-Bus error occured/An unexpected D-Bus error occurred/g' po/*.po po/*.pot
cd po
ls | sed -n 's/\.po$//p' > LINGUAS
intltool-update --pot --gettext-package=avahi
for i in `cat LINGUAS`; do intltool-update --dist $i; done
cd ..
cd ..
diff -urN avahi-0.6.31 avahi-0.6.31p > 9999-update-tanslations.patch
diff -uN avahi.spec.ori avahi.spec
--- avahi.spec.ori	2015-10-09 21:13:55.095798425 +0200
+++ avahi.spec	2015-10-09 21:18:05.179049758 +0200
@@ -97,6 +97,8 @@
 
 Patch107:         avahi-remove_lennart_prefix.patch
 
+Patch9999:        9999-update-tanslations.patch
+
 %description
 Avahi is a system which facilitates service discovery on
 a local network -- this means that you can plug your laptop or
@@ -379,6 +381,9 @@
 %patch105 -p1 -b .reserve-size
 %patch106 -p1 -b .invalid_packet
 %patch107 -p1 -b .remove_lennart_prefix
+
+%patch9999 -p1 -b .99999
+
 rm docs/INSTALL
 
 # patch101 requires autogen
Comment 3 Robert Antoni Buj Gelonch 2015-10-09 15:34 EDT
Created attachment 1081405 [details]
patch for updating translations v2
Comment 4 Robert Antoni Buj Gelonch 2015-10-10 06:01:52 EDT
I'm sorry, I forgot to review the Catalan UI, new patch in progress.
Comment 5 Robert Antoni Buj Gelonch 2015-10-10 06:07 EDT
Created attachment 1081582 [details]
patch for updating translations v3
Comment 6 Rex Dieter 2015-10-10 08:27:19 EDT
Thanks.

Looks like a new avahi-0.6.32-rc release was made, we can probably pick up the latest translations from there
Comment 7 Rex Dieter 2015-10-10 08:44:11 EDT
Assuming... these updated translations made it upstream.  On casual inspection, I don't think they did.
Comment 8 Robert Antoni Buj Gelonch 2015-10-10 09:25:18 EDT
Ok, I'll do a pull request at https://github.com/lathiat/avahi
Comment 9 Rex Dieter 2015-10-10 09:36:49 EDT
Thanks again, that would be ideal.

In the meantime, I've updated master/ branch to 0.6.32-rc as threatened, and if you rebase your work-in-progress patch against that, we can consider including it in fedora packaging (at least until it gets accepted upstream).

I couldn't rebase the patch myself, I don't have a transifix account, so the tx pull step fails,
$ tx pull -fas
/home/rdieter1/.transifexrc not found.
Exception: No user credentials found for host https://www.transifex.com. Edit ~/.transifexrc and add the appropriate info in there.

I'm not sure if this would be possible to do anonymously, or what is expected to be in ~/.transifixrc  (admittedly I didn't look very hard).  But, if you could provide instructions to be able to anonymously reproduce the patch, that would be great too. :)
Comment 10 Piotr Drąg 2015-10-10 10:58:09 EDT
(In reply to Rex Dieter from comment #6)
> Looks like a new avahi-0.6.32-rc release was made, we can probably pick up
> the latest translations from there

So is https://github.com/lathiat/avahi the new official upstream? Should we update https://l10n.gnome.org/module/avahi/ to instruct translators to send pull requests there?

Pulling the latest translations from Transifex first is, of course, a good idea. We don't want to waste any of translators' work.
Comment 11 Rex Dieter 2015-10-10 11:37:20 EDT
Good question.

I don't know if the use of github (fork?) is temporary (for the rc only) or not.

It definitely has more activity than,
http://git.0pointer.net/avahi.git
with last commit from 2013
Comment 12 Robert Antoni Buj Gelonch 2015-10-10 13:28:41 EDT
There is a public announcement at http://www.avahi.org/
Comment 13 Rex Dieter 2015-11-19 13:33:35 EST
%changelog
* Thu Nov 19 2015 Rex Dieter <rdieter@fedoraproject.org> 0.6.32-0.4.rc
- pull in upstream fixed, translations mostly (#1270332)
Comment 14 Fedora Update System 2016-01-25 12:55:43 EST
avahi-0.6.32-0.4.rc.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-31e7dea0f9
Comment 15 Fedora Update System 2016-01-25 23:27:46 EST
avahi-0.6.32-0.4.rc.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-31e7dea0f9
Comment 16 Fedora Update System 2016-01-28 13:21:37 EST
avahi-0.6.32-0.4.rc.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.