Bug 1270341 - qemu-kvm build failure race condition in tests/ide-test
Summary: qemu-kvm build failure race condition in tests/ide-test
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm
Version: 7.3
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: John Snow
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1272523 1273098 1285124
TreeView+ depends on / blocked
 
Reported: 2015-10-09 17:10 UTC by John Snow
Modified: 2015-11-24 23:07 UTC (History)
14 users (show)

Fixed In Version: qemu-kvm-1.5.3-105.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1272523 1273098 (view as bug list)
Environment:
Last Closed: 2015-11-19 05:12:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2213 0 normal SHIPPED_LIVE qemu-kvm bug fix and enhancement update 2015-11-19 08:16:10 UTC

Description John Snow 2015-10-09 17:10:26 UTC
Description of problem:

The tests/ide-test qtest has a flush_test that races during the qemu-kvm build process. It may fail on sufficiently fast hardware.

Version-Release number of selected component (if applicable):

qemu-kvm-1.5.3-104+

How reproducible:

Depends on your hardware. If it is sufficiently fast, it can be close to 100%.

Steps to Reproduce:
1. Attempt to build RPM
2. Build process fails while running make check

Or, if you build the source manually from the exploded tree:
1. configure --target-list="x86_64-softmmu"
2. make
3. make check

Actual results:

RPM build process fails due to test failure.

Expected results:

RPM build process reliably succeeds.

Additional info:

The flush test relies on the "qemu-io" HMP command to pause execution of the flush command in order to perform the test reliably without races. The qemu-io HMP command was not introduced until upstream qemu 1.6.0, so the test as it exists downstream races, leading to occasional failures.

Comment 9 Jeff Nelson 2015-10-16 21:46:30 UTC
Fix included in qemu-kvm-1.5.3-105.el7

Comment 15 juzhang 2015-10-20 04:34:42 UTC
According to comment11, set this issue as verified.

Comment 17 errata-xmlrpc 2015-11-19 05:12:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2213.html


Note You need to log in before you can comment on or make changes to this bug.