Bug 1270354 - Change to network state should refresh software sources
Change to network state should refresh software sources
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.1
All Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Jiri Konecny
Release Test Team
:
Depends On:
Blocks: 1256306
  Show dependency treegraph
 
Reported: 2015-10-09 14:25 EDT by Pat Riehecky
Modified: 2017-02-09 03:56 EST (History)
6 users (show)

See Also:
Fixed In Version: anaconda-21.48.22.82-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1272124 (view as bug list)
Environment:
Last Closed: 2016-11-03 19:17:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pat Riehecky 2015-10-09 14:25:11 EDT
Description of problem:
Currently it is possible to convince anaconda to attempt a network installation based on settings that are no longer in use.

Version-Release number of selected component (if applicable):anaconda-19.31.123-1


How reproducible:100%


Steps to Reproduce:
1.boot off of netboot.iso
2.configure all settings for a valid connection to the RHEL yum repo
3.reconfigure the network to an address with no connectivity
4.Begin installation

Actual results:
Anaconda formats the drives and then, after a long wait, produces an error that the repo timed out

Expected results:
When the network settings are changed, access to the installation sources is validated to ensure it still works.

Additional info:
Comment 2 Pat Riehecky 2015-10-15 10:23:34 EDT
https://github.com/rhinstaller/anaconda/pull/411

Seems to resolve my use cases.
Comment 4 Peter Kotvan 2016-07-21 09:14:58 EDT
If one boots only boot.iso without any installation source specified anaconda still tries to verify the empty source and thus renders installation source and software selection spokes unclickable for approximately 30 seconds after entering the main configuration screen. The check happens again after turning on the network so user has to wait for another 30 seconds to finally set the installation source.

This should be probably fixed.

During verifying this bug I found two more issues: #1358778 and #1358788
Comment 5 Jiri Konecny 2016-07-25 11:42:20 EDT
PR: https://github.com/rhinstaller/anaconda/pull/712
Comment 7 Peter Kotvan 2016-08-18 07:09:16 EDT
Verified on RHEL-7.3-20160817.1 with anaconda-21.48.22.82-1.el7.
Comment 9 errata-xmlrpc 2016-11-03 19:17:57 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2158.html

Note You need to log in before you can comment on or make changes to this bug.