Bug 1270369 - On shutdown, systemd tries to unmount network shares after NetworkManager is stopped, resulting in a long delay on wireless
On shutdown, systemd tries to unmount network shares after NetworkManager is ...
Status: CLOSED DUPLICATE of bug 1214466
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
22
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-09 15:27 EDT by Adam Williamson
Modified: 2015-10-12 03:36 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-12 03:36:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
journal from an affected boot (1006.91 KB, text/plain)
2015-10-09 15:28 EDT, Adam Williamson
no flags Details

  None (edit)
Description Adam Williamson 2015-10-09 15:27:07 EDT
On my F22 laptop, I have a couple of shares in /etc/fstab :

//nas/Media	/share/data	cifs	noauto,nosuid,soft,guest,uid=99,gid=99,file_mode=0777,dir_mode=0777,users,comment=systemd.automount	0 0
ircproxy:/	/share/irclogs	nfs	noauto,user,comment=systemd.automount	0 0

it seems that on shutdown, systemd attempts to stop these after NetworkManager has already stopped. Obviously at that point it's not going to be able to unmount them cleanly.

Attaching a log: you can see that shutdown is triggered at 10:28:57, NetworkManager is taken down in the same second, and errors from CIFS and NFS start showing up around 10:30:11:

Oct 09 10:30:11 xps13.happyassassin.net kernel: CIFS VFS: Server nas has not responded in 120 seconds. Reconnecting...

by 10:30:47 it's given up on the CIFS mount:

Oct 09 10:30:47 xps13.happyassassin.net systemd[1]: Unmounted /share/data.

but the NFS mount holds it up much much longer. At 10:31 there's this message:

Oct 09 10:31:58 xps13.happyassassin.net systemd[1]: share-irclogs.mount unmounting timed out. Stopping.

but in fact it just keeps hitting NFS timeouts right up until the reboot.target job times out, half an hour after it started:

Oct 09 10:58:57 xps13.happyassassin.net systemd[1]: Job reboot.target/start timed out.

whereupon the system finally shuts down.

systemd-219-24.fc22.x86_64
Comment 1 Adam Williamson 2015-10-09 15:28 EDT
Created attachment 1081404 [details]
journal from an affected boot
Comment 2 Adam Williamson 2015-10-09 15:48:43 EDT
So I think the connection being wireless is significant here. On a wired connection, even after NetworkManager.service is stopped, the connection remains active. On a wireless connection this is not the case.
Comment 3 Jan Synacek 2015-10-12 03:36:44 EDT

*** This bug has been marked as a duplicate of bug 1214466 ***

Note You need to log in before you can comment on or make changes to this bug.